Rclone sync ignoring errors and keep going

Hi all,
I found the solution;
–ignore-times instead of --ignore-checksum

tnx anyway!

Hi guys,
I’m doing a rclone sync mydata GCP:my-bucket. It’s a 8tb of not very large files, and some of these source files may change or vanish during my synchronization.

My goal is to keep rclone going no matter if a file is missing or changed during the sync. I’ve tried with:
rclone sync --ignore-checksum mydata GCP:my-bucket, but no luck.

I found posts explaining how to take snapshots, to make retries, etc, but in this case I’m not interested on these changed and/or deleted files; I’d just like to ignore these errors and keep the thing running no matter what.

Any thoughts?
tnx & best regards,
fviotti

Those shouldn’t cause rclone to stop, but they can cause corrupted on transfer errors - is that what you’ve been seeing?

I’m using rclone within a systemd service, so the error has actually stopped the service. Since I moved to --ignore-times the service has worked fine.
Tnx!

1 Like