Rclone sync gcs aws fails with `directory not found`

I am trying to sync gcs bucket with aws s3, and I am getting this error. It seems to be pretty simple, but I have no idea what am I doing wrong.

So, I created the config file with rclone config, and it looks like this:

[aws]
type = s3
provider = AWS
env_auth = false
access_key_id = KEY
secret_access_key = SECRET
region = eu-west-2
endpoint = ""
location_constraint = eu-west-2
acl = private

[gcs]
type = google cloud storage
project_number = NUMBER
service_account_file = /home/USER_NAME/creds/rclone.json
location = europe-west3

Then, what I do is to run the following command:
rclone sync gcs:BUCET-NAME aws:BUCKET-NAME

But it fails with not being able to resolve the host (no such host), as it tries with https(colon-slash-slash)BUCKET-NAME. So I do it this way:
rclone sync gcs:console(dot)cloud(dot)google(dot)com/storage/browser/GCS-BUCKET aws:AWS-BUCKET -P --dry-run

And it fails with Failed to sync: directory not found

I also tried passing aws http endpoint, and still fails. And also tries adding a slash in the end, like if it would be root path, but again fails.

There are not much logs. It just says that it is using this version, and that service account file, but nothing relevant.

rclone: Version "v1.56.2"

hello and welcome to the forum,

before trying to sync, make sure it remote works
rclone lsd aws: -vv
rclone lsd gcs: -vv

and enclose the output with three backticks so it looks like

rclone version
rclone v1.56.0
- os/version: Microsoft Windows 10 Pro 2009 (64 bit)
- os/kernel: 10.0.19043.1266 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.16.5
- go/linking: dynamic
- go/tags: cmount

Thank you so much. rclone lsd aws: -vv was failing with no such host. I had to change the endpoint parameter by AWS host and now it works.