Rclone sync error : doesn't delete destination folders if not empty

STOP and READ USE THIS TEMPLATE NO EXCEPTIONS - By not using this, you waste your time, our time and really hate puppies. Please remove these two lines and that will confirm you have read them.

What is the problem you are having with rclone?

rclone sync doesn't delete old files and unempty directories on destination

Run the command 'rclone version' and share the full output of the command.

rclone v1.63.1

  • os/version: Microsoft Windows 10 Home 22H2 (64 bit)
  • os/kernel: 10.0.19045.3208 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.20.6
  • go/linking: static
  • go/tags: cmount
yes : 1.63.1

Which cloud storage system are you using? (eg Google Drive)

pCloud

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync --log-level=DEBUG --checksum --delete-before --ignore-errors --progress C:\Users\Jean-Paul\Desktop crypto_pcloud:Desktop

The rclone config contents with secrets removed.

[pcloud]
type = pcloud
hostname = api.pcloud.com
token =  xxxxxxxxxx

[crypto_pcloud]
type = crypt
remote = pcloud:sauvegarde_rclone/pcloud_protocol
filename_encryption = off
directory_name_encryption = false
password = yyyyyyyyyyy
password2 =  zzzzzzzzzzzz

A log from the command with the -vv flag

2023-07-23 17:48:34 DEBUG : recup/n8ria5dm02m50q99he5hmmhrh9qoe14trprqv47vbfc38cmr2gk0: Skipping undecryptable file name: not an encrypted file - does not match suffix
recup/calculatrices/casio/khiCAS: Failed to Rmdir: rmdir failed: pcloud error: Folder is not empty. (2006)
2023-07-23 18:12:06 INFO  : recup/calculatrices/TI/univers-ti: Removing directory
2023-07-23 18:12:07 DEBUG : recup/calculatrices/TI/univers-ti: Failed to Rmdir: rmdir failed: pcloud error: Folder is not empty. (2006)

Looks like you've mixed or changed how your encryption is setup.

You'd have to remove the offending files as that's why it won't delete as there are files left.

yes, you're wright, it works.
That's strange, i thought it would delete anything but the files from source or identical to source.
Thank you, and sorry for inconvenience.
Regards,

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.