Rclone stopped working since some day

What is the problem you are having with rclone?

stopped working

Run the command 'rclone version' and share the full output of the command.

root@api-crm:~# rclone version
rclone v1.63.0

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: 5.15.0-76-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20.5
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

google drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount --daemon --allow-other gdrive-wa: gdrive-wa/ --uid=33 --gid=33

The rclone config contents with secrets removed.

[gdrive-wa]
type = drive
scope = drive
token = {"access_token":"ya29.a0AbVbY6N4u3_6jgf9t-Z3EWE24I5mLD5HFgGGrNHgk9NYlbLclJVIVsVMmqke6Lx24rOScxOKl5Bb_gCb_7KQjx38lFijAJZiIqCcweSwsYqUtJYdFxv6heuEbuZwQdZpHtp34OUmS1P0HYljf2VylMwoqsl86aHSaCgYKAfESARMSFQFWKvPlTj61s9rvkct39zIz8ZqUSA0167","token_type":"Bearer","refresh_token":"1//09dst8a2U13YbCgYIARAAGAkSNwF-L9Irkrb2CyJi-lXd3B0paxYtgIN8uKAnE0YH2eIrP2Q3pextuNFPkrHYeYuo5xKfqndKl7M","expiry":"2023-07-17T13:43:28.94707027+02:00"}

A log from the command with the -vv flag

2023/07/17 12:48:00 DEBUG : rclone: Version "v1.63.0" starting with parameters ["rclone" "mount" "--daemon" "--allow-other" "gdrive-wa:" "gdrive-wa/" "--uid=33" "--gid=33" "-vv"]
2023/07/17 12:48:00 DEBUG : Creating backend with remote "gdrive-wa:"
2023/07/17 12:48:00 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2023/07/17 12:48:00 DEBUG : Google drive root '': 'root_folder_id = 0ADnhptmbFhVhUk9PVA' - save this in the config to speed up startup
2023/07/17 12:49:00 DEBUG : Daemon timed out. Terminating daemon pid 172979
2023/07/17 12:49:00 Fatal error: mount not ready

until last friday was working correctly, I did not change anything in the meanwhile...
thanks

run the same mount command without --daemon flag and post output here

without that option it seems working now... but I need it

root@api-crm:/var/www# rclone mount --allow-other gdrive-wa: gdrive-wa/ --uid=33 --gid=33 -vv
2023/07/17 14:08:10 DEBUG : rclone: Version "v1.63.0" starting with parameters ["rclone" "mount" "--allow-other" "gdrive-wa:" "gdrive-wa/" "--uid=33" "--gid=33" "-vv"]
2023/07/17 14:08:10 DEBUG : Creating backend with remote "gdrive-wa:"
2023/07/17 14:08:10 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2023/07/17 14:08:11 DEBUG : Google drive root '': 'root_folder_id = 0ADnhptmbFhVhUk9PVA' - save this in the config to speed up startup
2023/07/17 14:08:11 DEBUG : Google drive root '': Mounting on "gdrive-wa/"
2023/07/17 14:08:11 DEBUG : : Root:
2023/07/17 14:08:11 DEBUG : : >Root: node=/, err=<nil>
2023/07/17 14:08:15 DEBUG : /: Attr:
2023/07/17 14:08:15 DEBUG : /: >Attr: attr=valid=1s ino=0 size=0 mode=drwxr-xr-x, err=<nil>
2023/07/17 14:08:25 DEBUG : /: Attr:

This is good news that mount works.

Now why daemon does not is more complex... It is been reported from time to time that it happens on some linux distros. Not sure anybody knows why...

You can try to update your linux:

sudo apt update && sudo apt upgrade

to see if it helps.

Otherwise you can switch to using systemd

1 Like

Can you share what helped? Updating system? Or switching to systemd?

On your daemon command, you can add --log-file /some/location/rclone.log --log-level DEBUG and you'll see why it timed out.

the section name was wrong, now the systemd solution works perfectly, thanks again!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.