Rclone stopped connecting to Gdrive

What is the problem you are having with rclone?

Rclone was working few days ago but I was able to mount yesterday so I deleted remote and tried creating a new one but it gives me this error

NOTICE: Log in and authorize rclone for access
NOTICE: Waiting for code...
NOTICE: Got code
Error: failed to get token: Post "https://oauth2.googleapis.com/token": dial tcp connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

I get the success message in the browser and I have switched off windows firewall and deleted vpn. Tried everything that was available on the forum. Please Help

Run the command 'rclone version' and share the full output of the command.

rclone v1.57.0

  • os/version: Microsoft Windows 10 Home 2009 (64 bit)
  • os/kernel: 10.0.19044.1466 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.17.2
  • go/linking: dynamic
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Choose a number from below, or type in your own value.
 1 / Full access all files, excluding Application Data Folder.
   \ "drive"
 2 / Read-only access to file metadata and file contents.
   \ "drive.readonly"
   / Access to files created by rclone only.
 3 | These are visible in the drive website.
   | File authorization is revoked when the user deauthorizes the app.
   \ "drive.file"
   / Allows read and write access to the Application Data folder.
 4 | This is not visible in the drive website.
   \ "drive.appfolder"
   / Allows read-only access to file metadata but
 5 | does not allow any access to read or download file content.
   \ "drive.metadata.readonly"
scope> 1
Option root_folder_id.
ID of the root folder.
Leave blank normally.
Fill in to access "Computers" folders (see docs), or for rclone to use
a non root folder as its starting point.
Enter a string value. Press Enter for the default ("").
Option service_account_file.
Service Account Credentials JSON file path.
Leave blank normally.
Needed only if you want use SA instead of interactive login.
Leading `~` will be expanded in the file name as will environment variables such as `${RCLONE_CONFIG_DIR}`.
Enter a string value. Press Enter for the default ("").
Edit advanced config?
y) Yes
n) No (default)
Use auto config?
 * Say Y if not sure
 * Say N if you are working on a remote or headless machine

y) Yes (default)
n) No

The rclone config contents with secrets removed.

type = drive
client_id = xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
client_secret = xxxxxxxxxxxxxxxxxxx
scope = drive

A log from the command with the -vv flag

Paste  log here

There was another post about that as well and that looks like another India based address (?).

Seems like something on the ISP side is blocking you if you are sure there isn't a firewall/AV/etc.

This person had the same problem:

Port 443 timing out on rclone config reconnect - Help and Support - rclone forum

Unfortunately, nothing rclone can do about that as you could try a VPN or ask the ISP (not sure if they will say anything).

Thanks a lot. I'll try that

Used VPN to get the token. Works fine now

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.