Rclone speed dropdowns

Hey guys,

I have mounted locally a GDRIVE unit, and I have observed, that when copying I am having some speed dropdowns:


I am using this config for the mount:

ExecStart=/usr/bin/rclone mount \
        --config=/root/.config/rclone/rclone.conf \
        --allow-other \
        --cache-tmp-upload-path=/tmp/rclone/upload \
        --cache-chunk-path=/tmp/rclone/chunks \
        --cache-workers=20 \
        --cache-writes \
        --cache-dir=/tmp/rclone/vfs \
        --cache-db-path=/tmp/rclone/db \
        --no-modtime \
        --buffer-size=500M \
        --drive-chunk-size=1G \
        --drive-use-trash \
        --stats=0 \
        --checkers=24 \
        --bwlimit=80M \
        --dir-cache-time=120m \
        --cache-info-age=120m encryptteam:/ /mnt/google
ExecStop=/bin/fusermount -u /mnt/google

On the other hand when I run a simple rclone copy command, these drop downs are not happening. Any idea on why? Do I need to add any other flags to my mount?

Kind regards

most of the help and support template questions was not answered?
help us to help you and provide the answers.

and using the cache remote, which has been deprecated, has bugs that will never get fixed.

emmm, sorry but I do not get you

pedro@plex:~$ rclone version
rclone v1.56.2

  • os/version: debian 10.10 (64 bit)
  • os/kernel: 4.19.0-17-amd64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.16.8
  • go/linking: static
  • go/tags: none

About the log thing, since it is a mount drive, don't know how can I share that with you

I can not get with the way of doing it :frowning:
Tried many different configs:

But it seems that after some seconds the speed goes down:

Only thing that was working was to enable --vfs-cache-mode=full but TBH I do not want my data to be cloned in local killing my NVME and just to be sent to the cloud.

Any idea?

can you post the rest of the help and support template?
--- redacted config file
--- full debug log that includes the period of slowdown

why use both at the same time?
--- deprecated cache remote
--- vfs file cache

why set --vfs-read-chunk-size=0?

as far as i know, --checkers does nothing on a mount.


This is my config file:

type = drive
client_id = XXX.apps.googleusercontent.com
client_secret = XXX
scope = drive
token = {"access_token":"XXX"}
team_drive = XXX
root_folder_id =

type = crypt
remote = team:
filename_encryption = standard
directory_name_encryption = true
password = XXX

And this is the log:

About the flags, don't know I tried many things and they were one.

Kind regards

for the debug log, at what exact time was there a slowdown?

Haven't checked the exact time the slowdown was happening. I can try again and let you know.
Now, about the flags, I thought the global flags could also be used:

I have tried to check again, and during a tail -f it just stops the output, and progress it back after some seconds. In the log I attached, you can see the time in lines jumping:

2022/02/08 18:43:16 DEBUG : &{prueba/After We Fell (2021) [WEB-DL 2160p HEVC SDR ES DD+ 5.1 - EN DD 5.1 Subs][HDO].mkv (w)}: Write: len=131072, offset=2146304000
2022/02/08 18:43:38 DEBUG : &{prueba/After We Fell (2021) [WEB-DL 2160p HEVC SDR ES DD+ 5.1 - EN DD 5.1 Subs][HDO].mkv (w)}: >Write: written=131072, err=

From 16 seconds to 38

The speed drops are probably google writing that 1GB of data to disk. Do you think they happen about every 1GB? I think they happen after about 30 seconds of transfer at 50MByte/s so that sounds about right.

Try decreasing --drive-chunk-size. You could also try --vfs-cache-mode writes which should be faster and more reliable for uploads but it will temporarily duplicate your data locally.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.