Rclone size dropbox "too many requests"

STOP and READ USE THIS TEMPLATE NO EXCEPTIONS - By not using this, you waste your time, our time and really hate puppies. Please remove these two lines and that will confirm you have read them.

What is the problem you are having with rclone?

Rclone size on dropbox produces "Too many requests or write operations. Trying again in 300 seconds." and the command is never completed for bigger mounts.

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.0

  • os/version: debian 12.4 (64 bit)
  • os/kernel: 6.1.0-15-amd64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.4
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Dropbox

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone size dropbox: --log-file /

Paste command here

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

Paste config here

A log from the command that you were trying to run with the -vv flag

Paste  log here

You need to create your own client ID and secret.

You need to limit the tps to 12 per client ID/secret you've made.

Ok thanks. So 1 another client id to use for queries like this and 2 --tpslimit 12 when using rclone size on dropxbox?

Answering myself, if anyone sees this in the future with similar challenges.

I believe I found a workaround by running a copy or move operation with the dry-run flag.

This will take forever if there is a lot of data but produce a nice report of the current size of what is included as copy/move from in the command.

As long as the destination has none of the files (I've used a temp directory for the dry-run command in this case)

What do you mean? You just need to limit the tps and it works.

Each client ID/secret works with about 12 tps.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.