RClone SFTP failed to create file system on Synology, works on MacOS

I’m trying to use rclone to access an SFTP site. Running 1.42 on both MacOS and on my Syno NAS. Running

rclone ls myremote:/

works fine on the Mac. When I run it on the NAS I get this:

2018/08/22 15:52:04 Failed to create file system for “myremote:/”: NewFs: couldn’t connect SSH: dial tcp xxx.xxx.xxx:22: i/o timeout

Both remotes were set up with identical user/host/password/other settings.

Any idea why?

Just for completeness, I tried with the latest beta (v1.42-126-g3751ceebβ) and same issue.

Nobody else seen this?!

Any logging etc I can do to help with debugging? :slight_smile:

I’m not really a Synology guy, but on the device, can you telnet out to port 22 on the IP specified and does it connect?

The message seems to be related to not being able to connect which I would think means something is blocking it.

Aha! Good point - didn’t think about trying that. D’oh.

And of course, you’re absolutely right, I can’t ssh to that address either. Interestingly, if I disconnect the VPN network interface on the NAS, it all springs into life, so it looks like there’s an issue with SSH over my VPN - either for that particular account, or potentially all accounts.

Good spot - thanks!