Rclone serve authentication timeout?

What is the problem you are having with rclone?

It is not a problem more of a security bug? Once the authentication is established on rclone serve using proxy auth if the password changes on the call on to the proxy.exe while the serve is still running the client connection still connects afterwards.

I apologize if I did not explain my question correctly.

What is your rclone version (output from rclone version)

rclone v1.49.3

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 2012 R2

Which cloud storage system are you using? (eg Google Drive)

rclone serve webdav

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone serve webdav --addr :444 --auth-proxy proxy.exe

Are you doing all the authentication in the auth proxy?

If so then, if the user keeps the connection open (or at least doesn't let it drop for more than 1 minute) then the auth proxy script won't be called again. If the user stops using the service for > 1 minute the auth proxy will be called again.

What do you think rclone should do here - call the auth proxy for every incoming auth? This is possible? My thinking was that usually the auth is done by the cloud provider so not calling the auth proxy every time is OK and more efficient. Maybe that should be an option rather than the default?


Yes your correct, I'm using auth proxy to execute the authentication.

I would recommend as far as for the serve option to be able to set and call the auth proxy at every incoming auth if its possible. Or have a way to increase the timeout to a desired amount?

But a default 1 min is acceptable, I just didn't know what the timeout was. I appreciate the response.

Perhaps making an --auth-proxy-cache-time flag or similar would be the thing. By default this is 1 minute, but if you set it to 0 then rclone will call the auth proxy for every auth.

Fancy making a new issue on github about that? (Put a link to this forum page)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.