Rclone, openbsd, take *odt?

hello
Im attempting to reproduce my little documents backup system with rclone to a server
Im doing it under linux, like :
rclone sync -P /home/user/*odt server:/odt/
trying into openbsd :
rclone sync -P /home/user/*odt server:/odt/

results in:
rclone sync -P "/home/user/"*odt 'server:/odt <
Usage:
rclone sync source:path dest:path [flags]

Flags:
--create-empty-src-dirs Create empty source dirs on destination after sync
-h, --help help for sync

Use "rclone [command] --help" for more information about a command.
Use "rclone help flags" for to see the global flags.
Use "rclone help backends" for a list of supported services.
Command sync needs 2 arguments maximum: you provided 3 non flag arguments: ["/home/user/abc.odt" "/home/user/def.odt" "server:/odt/"]

how could I get it solved?
I already tried with brackerts ".." or '..' for the server... or using ~/*odt or /home/*odt for the source part.. didnt worked..
thank you for helping!

hello and welcome to the forum,

when you posted, there was a template of questions.

sorry, I did my best :

What is the problem you are having with rclone?

problem of syntax, differences between nux and obsd

Run the command 'rclone version' and share the full output of the command.

rclone v1.56.0-DEV

  • os/version: OpenBSD
  • os/kernel: unknown
  • os/type: openbsd
  • os/arch: amd64
  • go/version: go1.17
  • go/linking: dynamic
  • go/tags: none

vs

rclone v1.53.3-DEV

  • os/arch: linux/amd64
  • go version: go1.15.9

Are you on the latest version of rclone? You can validate by checking the version listed here: Rclone downloads
Im afraid no, I cant manage version fron openbsd ports

Which cloud storage system are you using? (eg Google Drive)

nextcloud and pcloud, but it doesnt matters, it's a syntax problem (it doesnt starts upload)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Im doing it under linux, like :
rclone sync -P /home/user/*odt server:/odt/
trying into openbsd :
rclone sync -P /home/user/*odt server:/odt/

results in:
rclone sync -P "/home/user/"*odt 'server:/odt <
Usage:
rclone sync source:path dest:path [flags]

Flags:
--create-empty-src-dirs Create empty source dirs on destination after sync
-h, --help help for sync

Use "rclone [command] --help" for more information about a command.
Use "rclone help flags" for to see the global flags.
Use "rclone help backends" for a list of supported services.
Command sync needs 2 arguments maximum: you provided 3 non flag arguments: ["/home/user/abc.odt" "/home/user/def.odt" "server:/odt/"]

The rclone config contents with secrets removed.

--
Paste config here

A log from the command with the -vv flag

well, when I add -vv, it looks its still interrupted

best to update both to the latest stable is v1.60.0
https://rclone.org/downloads/#script-download-and-install
or to download it manually
https://rclone.org/downloads/#release

are you trying to sync a dir named *odt
or
trying to sync all dirs that contain odt?
if so, then
rclone sync -P /home/user/ server: --include='*odt*' --dry-run

and please enclose the text with backticks so it formatted correctly.
image

well thank you, it worked with the --include='odt' --dry-run options
Id like to know also if there is a solution for getting only "simple text" files, without extension
sometimes Im writing notes under linux with xed or leafpad, as so under openbsd with leafpad ; only name is asked for saving them, so I do. Means there is no extension unlike libreoffice requires to save file in .od* ; however, Id like to know if it was possible to save all "text" simple files (eg ones wrote with nano, leafpad or xed) only, to avoid little extensionless files made in .config or .cache directories, but linked to the system (and not wrote by me)
would it be possible to do so?
thank you again :slight_smile:

fwiw, best to test filters using rclone ls

rclone ls . 
        1 file
        1 file.ext

rclone ls . --exclude=*.{*} 
        1 file