Rclone not respecting upload limiter?

What is the problem you are having with rclone?

Rclone is not respecting the upload limiter to onedrive.

What is your rclone version (output from rclone version)

rclone v1.45

  • os/arch: linux/amd64
  • go version: go1.11.6

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Debian 10, 64-bit

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy /mnt/Music onedrive:Music --exclude-from /rclone/exclude --bwlimit 1M --verbose

The rclone config contents with secrets removed.

type = onedrive
token = {"access_token": redacted }
drive_id = redacted
drive_type = personal

rclone uploads just fine, and even using --verbose it looks like it is respecting the bandwidth limiting flag, but according to my router, when that command is running I see ~8-9 megabit/s upload rate from the computer running it. This is a problem because I have a 10Mb upload rate limit on this connection. The internet bogs down for everyone else doing anything, and works just fine when I cancel the transfer.

Sidenote: It's probably not a queuing problem - the router is running OpenWRT 19.07.2 with cake SQM - see openwrt [dot] org/docs/guide-user/network/traffic-shaping/sqm-details

hello and welcome to the forum,

Options which use SIZE use kByte by default. However, a suffix of b for bytes, k for kBytes, M for MBytes, G for GBytes, T for TBytes and P for PBytes may be used
to limit bandwidth usage to 10 MBytes/s use --bwlimit 10M

--bwlimit 1M is 1MB/s which is approx 10Mb/s
and your connection is 10Mb/s.
so in effect, you are not limiting your internet connection.

also, the version of rclone you are running is 18 months old


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.