Rclone not reporting upload completion?

What is the problem you are having with rclone?

Rclone does not output any status message/ completion message after an upload is complete. For example, when I do rclone copy temp GDrive:/cards
It does upload the files in the temp folder, though doesn't create a temp directory as I thought it would, and stays silent even after all the uploads are completed.

What is your rclone version (output from rclone version)

Latest version?

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Fedora v28, 64bits.

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

Rclone copy temp GDrive:/cards (also tried sync instead of copy)

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

  1. if you want to see output you need add a flag,
    read this https://rclone.org/docs/#log-level-level
  2. if you want the folder created on the dest, you need to specify it.
  3. when testing commands,especially sync, which will delete files, use this flag.

try this
Rclone copy temp GDrive:/cards/temp -v --dry-run

1 Like

Well said,

But it is probably simpler to just start with adding
(or just -P for short)

This will show the basic stats of what is going on in the transfer and will make it obvious when it is done.

adding -v or --verbose will give a load of extra (different) info about every file, but this might be a bit to much for what you are really asking for here... I'd suggest just trying -P first.

rclone only works on what is "inside" the locations you specify, so if you want the files to go to a "temp" folder on the GDrive then you need to specify it as part of the destination - exactly asasdffdsa shows in his example.

1 Like

Hello guys,
Thank you both for your replys.
I am a complete linux and rclone newb, hence things which are obvious might not be so for me. :slight_smile:
I have been using this guide here to setup rclone

That guide showed that there would be an output in the form of 8 files copyed in xx seconds (or the speed shown in kbps) after the upload was completed.
That guide did not use any flags such as progress or v, hence I did not use them, although I suppose he very well could have and not mentioned it there.
Hence the rclone behaviour was unexpected for me I.E it not showing upload completion in the output.

Also, should sync not replicate the entire directory structure?
I.E if you had a folder temp, and 2 directories inside it temp 1 and temp 2, along with file1.txt and file2.txt, if you were to type sync temp GDrive:/
What would you expect rclone would do in such a case? would it not create a temp directory first, and place temp 1 and 2 directories inside it, along with file 1 and 2?
I tried that, and what rclone did was created the temp 1 and 2 directories file 1.txt and file2.txt but did not create the temp folder first in which all these folders and files were.
Thank you again, I will check these both commands out and report back with the findings.

Rclone doesn't do that without the -v flag. However it is possible the author wrote the article using an old version of rclone v1.36 or before (released in Feb 2017) which does have that behaviour.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.