Rclone Nextcloud WebDav lists nothing

STOP and READ USE THIS TEMPLATE NO EXCEPTIONS - By not using this, you waste your time, our time and really hate puppies. Please remove these two lines and that will confirm you have read them.

What is the problem you are having with rclone?

I create a new config which points to a webdav nextcloud. When I run rclone ls mynextcloud:, I get NOTICE: Chunks temporary upload directory: https://domain/user/nextcloud/remote.php/dav/uploads/user/ and nothing lists.

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.2

  • os/version: debian 11.8 (64 bit)
  • os/kernel: 6.5.11-x64v3-xanmod1 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.6
  • go/linking: static
  • go/tags: none
Yes, it is latest version

Which cloud storage system are you using? (eg Google Drive)

Nextcloud WebDAV

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone ls mynextcloud:

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[mynextcloud]
type = webdav
url = https://domain/nextcloud/remote.php/dav/files/user
vendor = nextcloud
user = user
pass = redacted

A log from the command that you were trying to run with the -vv flag

2024/01/27 14:52:48 DEBUG : rclone: Version "v1.65.2" starting with parameters ["rclone" "ls" "mynextcloud:" "-vv"]
2024/01/27 14:52:48 DEBUG : Creating backend with remote "mynextcloud:"
2024/01/27 14:52:48 DEBUG : Using config file from "/home/tester/.config/rclone/rclone.conf"
2024/01/27 14:52:48 DEBUG : found headers:
2024/01/27 14:52:48 NOTICE: Chunks temporary upload directory: https://domain/user/nextcloud/remote.php/dav/uploads/user/
2024/01/27 14:52:49 DEBUG : 6 go routines active

hi,
do you have files in nextcloud?
which other webdav clients have you tried?

Yes, I have files and folders

I didn’t try other WebDAV, only this one.

Also I tried to upload a file to remote and I get 403 error.

fwiw, the first step is to make sure the server works by testing with another webdav tool or native os mount.