Rclone mount to Google Drive fails

That is probably the problem. The kernel will be waiting for rclone for 10 minutes and it will timeout.

You can try setting this flag

  --daemon-timeout Duration                Time limit for rclone to respond to kernel (not supported on Windows) (default 0s)

Say --daemon-timeout 15m which might help. (The default is 10 minutes on macOS). There is an upper limit for it which I can't remember but it isn't very big. You may also be able to turn off this timeout using --daemon-timeout 0 which might also be worth a try.

When stuff goes wrong in kernel space, the system tends to suffer.