Rclone Mount Service not working?


#22

Now I am getting this error:

zcleaver@ubuntu:~$ systemctl start rclone-mount.service
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Authentication is required to start 'rclone-mount.service'.
Authenticating as: zcleaver,,, (zcleaver)
Password: 
==== AUTHENTICATION COMPLETE ===
Failed to start rclone-mount.service: Unit networkd-wait-online.service not found.

#23

You’d have to change it to the right name for the OS, which was the original name you had.

systemd-networkd-wait-online.service as that the service name you had enabled.


#24

Upon reboot-

zcleaver@ubuntu:~$ systemctl status rclone-mount.service
● rclone-mount.service - rclone FTP FUSE mount
   Loaded: loaded (/etc/systemd/system/rclone-mount.service; static; vendor pres
   Active: inactive (dead)
     Docs: http://rclone.org/docs/

Running this -

[Unit]
Description=rclone FTP FUSE mount
Documentation=http://rclone.org/docs/
After=systemd-networkd-wait-online.service
Requires=systemd-networkd-wait-online.service

[Service]
Type=simple
User=zcleaver
Group=zcleaver
ExecStart=/usr/bin/rclone mount oldseed:files/sync /opt/drive1/sync
ExecStop=/usr/bin/fusermount -uz /path/

[Install]
Wants=network-online.target

#25

Yeah, so it is mounted or not?