Rclone mount random slow speeds

It is not just an Australian problem, I'm in Spain and I also have slow speeds.

I've searched in nslookup.io page for google ips of several countries and, surprisingly, Russian ones gave me speeds of 30/35MiB/s

1 Like

Facing something similar issue from few days (5 july) please somebody help me.
when ever i start download something from googel drive in browser my download speed get stuck at 500KB/s if i download multiple file from google drive then each file will download at speed of 500KB/s. and i try to pause download and restart it then suddenly speed will go up to 6MB/s (my internet speed) and then it will drop to 500KB/s. let me clear this only happen to google drive file, any other file will download normaly at 6MB/s speed.
When i use vpn then i get full speed download at googel drive, so i thought that may be it is something to do with my isp but when i download android vm in my pc and download file inside google drive android app inside vm without vpn then my download speed get increase to 6MB/s. so there is nothing to do with my isp.

what i have trid:-

  1. update my windows system
  2. try using diffrent browser
  3. try using diffrent google account
    but still facing this issue

I am try to find solutin of this problem form few day on reddit then somebody suggest me this forum please can somebody help me to understand what is real issue and how can i fix it.

the script will output such message when grep is unable to find (case insensitive) either mib/s or kib/s in rclone's log file. so, it seems your log files are either using a different metric or do not contain such information. try running the following command on its own and then inspect the resulting log file to see what is going (edit the remote file and output dir before running, of course):

rclone copy --log-file ./rclone-standalone-run.log -v "REMOTE_FILE" "OUTPUT_DIR"

if you run into other issues or unable to solve this one, I think it is better to open an issue in the script's gh repo. (this thread is getting too long and am afraid that script troubleshooting is somewhat unrelated.)

I'd have to spin a windows vm to test that and unfortunately, I'm particularly busy this weekend. regarding your findings, are you able to run wireshark (or similar tool) on the same host that has the official gdrive app to see what is going on? that could prove instructive moving forward.

the issue is not restricted to Australia. I'm running into it in South America and we have reports from north america and europe as well.

I'm not hugely surprised. knowing how they deploy software and infrastructure changes. My assumption that this is bad configuration that is now "drifting" across their infra, and I'm sure it will be addressed (either change will be reverted or will be a 'roll-forward' fix)

They wouldn't have changed the TOS out of the blue for a paid, commercial service

1 Like

I've tried listing all IPs I could for European locations.

Two files, one is a text file with the listing of domain names and corresponding IPs (you'll notice the first three letters in the domain names refers to the city of the endpoint), the other is an open sheet with the list of IPs per country/city.

The first file has been deduplicated, the second file hasn't, simply listing the result of "nslookup www.googleapis.com" for any given location.

Pastebin to the first file: Name: fra24s06-in-f10.1e100.netAddress: fra24s - Pastebin.com

Download link for the open sheet: 6.1 KB file on MEGA

Look at my post 4 posts above you post, it has what you are looking for. Is your server in Australia or somewhere else?

From Malaysia here, the Singapore IP address works well for now. I have been facing this slowness for a week now, I thought it's my account or IP issue but my VPS located in the US also faced the same.

Hopefully google will fix this soon, it's unbearable consider that I am paying for google workspace as well.

A list of Dutch IPs that was missing from the Euro list above:

Name:    lhr26s05-in-f10.1e100.net

Name:    ams15s42-in-f10.1e100.net

Name:    ams15s40-in-f10.1e100.net

Name:    ams17s12-in-f10.1e100.net

Name:    ams16s32-in-f10.1e100.net

Name:    ams15s41-in-f10.1e100.net

Name:    ams15s44-in-f10.1e100.net

Name:    ams17s10-in-f10.1e100.net

Name:    ams15s48-in-f10.1e100.net

Name:    sof01s11-in-f106.1e100.net

I'm pretty sure the last one is from Sofia, Bulgaria but still.

i am in india so nearest server is mumbai

Cannot say thank you enough!

with a bit of script manipulation, i am now selecting best speeds from the USA/ singapore servers( from South africa). hope Google really fixes this mess


I have listed all the IP addresses for Mumbai above. You can either use the script to test them or test them out one by one.

  1. change your hosts file manually with a new ip address located in /etc/hosts

  2. then do a copy from google drive to your server
    rclone copy -v -P <rclone drive:/some/file /tmp

Then you can watch the download speed. If the speed is too slow, try another IP. e.g. do step 1 and step 2 again.


OR you can grab this script from @Nebarik and update the section that says edit these bits


Then run the script and it will do it all for you.

1 Like

actually i have problem in downloading inside browser. so i come here because i am unable to find answer any were.

It probably doesnt matter if you are using a browser or rclone or the Google drive client.I would test it out anyway.

Just do the manual method I put above about setting your hosts file manually.

Just an update, as mentioned the singapore servers have been rock solid for 2 days now.

Has anyone had any luck with google support looking into this?

1 Like

Are people running the checking script on a cron or schedule?

please guide me how can i run script in windows and what should i update "edite these bits section" with

The script is written in bash, which is a native linux language. You can get it to run in Windows, but you might find it difficult.

I would suggest testing with the Singapore servers first, even though they are far from India, they are working properly.

This method will take a while, but it is the simplist to explain.

  1. Go to c:\Windows\System32\drivers\etc\ and copy the file called hosts to your desktop
  2. Open notepad and drag the hosts file into the notepad to open it
  3. Add the line to the bottom of the file that looks like this
    IP_ADDRESS www.googleapis.com
    e.g. www.googleapis.com
  4. Click File > Save
  5. Copy the updated 'hosts' file from your desktop back to the file location c:\Windows\System32\drivers\etc\
  6. Click the Windows start button and type ipconfig /flushdns or restart the computer
  7. Test by downloading a file from Google Drive and see if it is any faster
  8. If it is faster, great, if its not faster, then repeat the above process using a different IP_ADDRESS from the list below.

Where I have written IP_ADDRESS replace it with an IP address from below


Seems my Rclone logs report in MBytes and not MiB's... so the scripts posted here don't work :frowning:

Is there anyway around this?

Have noticed recently my transfers are being limited to 2.5MB/s - based in West US

the most recent gdrive help center post that seems related to the download issue is from Jul 2nd (download files slow speed - Google Drive Community) and it has not been replied by google staff yet. to be honest, I doubt they will ever reply that post because of the way it was framed, even though the issue affects many of us who do not use gdrive just for streaming. in any case, the temporary solutions documented here have been working fairly well.

Hello all,

Here another one having this low speed ips issue...
Myself from Spain, so it seems all regions to be affected as far as I can see.

At the same time it would be nice, was people was talking before, any option to full cache the entire movie, once it is requested, don't know if placing --vfs-read-ahead 200G would fully cache the entire file while watching it, although it would not be multithread, and would be nice for it to be coded as such.
Or at the same time, to fully download the movie prior to the playback of it, in a multithread way also. People was talking about an rclone version that was doing such, but any idea on how?

Kind regards