Rclone Mount Issue


#1

Hi all,

I was having speed issues with Rclone Mount and that Plex was taking ages to play a file.

So I deleted my existing Gdrive Remote.

Rebooted.

Re added with a root folder the same as before.

When I play in plex the media is now missing.

If I browse the folder, /media/Plex its now empty?

I can’t seem to get my folder back and now my whole media server is down!

Help!!!

Jon.


#2

OK,

I got this working, however, it now takes an age to load anything…

click play on a movie, 10/15 seconds.

Thought it was plex, tried Emby, its the same.

:frowning: Why.

The whole reason I did this was to see if I could increase speed. When I started using Rclone Mount it would load my files in seconds.


#3

[Unit]
Description=Mount and cache Google drive to /media/Plex
After=syslog.target local-fs.target network.target

[Service]
Environment=RCLONEHOME=/home/plexuser/.config/rclone
Environment=MOUNTTO=/media/Plex
Environment=LOGS=/home/plexuser/logs
Environment=UPLOADS=/home/plexuser/uploads

Type=simple
User=root
ExecStartPre=/bin/mkdir -p ${MOUNTTO}
ExecStartPre=/bin/mkdir -p ${LOGS}
ExecStartPre=/bin/mkdir -p ${UPLOADS}
ExecStart=/usr/bin/rclone mount
–rc
–log-file ${LOGS}/rclone.log
–log-level INFO
–umask 022
–allow-non-empty
–allow-other
–fuse-flag sync_read
–tpslimit 10
–tpslimit-burst 10
–dir-cache-time=160h
–buffer-size=64M
–attr-timeout=1s
–vfs-read-chunk-size=2M
–vfs-read-chunk-size-limit=2G
–vfs-cache-max-age=5m
–vfs-cache-mode=writes
–cache-dir ${UPLOADS}
–config ${RCLONEHOME}/rclone.conf
Gdrive: ${MOUNTTO}
ExecStop=/bin/fusermount -u -z ${MOUNTTO}
ExecStop=/bin/rmdir ${MOUNTTO}
Restart=always


#4

You can adjust the chunk size to something larger than 2M as that’s super tiny.

Rather than tweaking, just remove and start with the defaults.