Rclone mount error. google Drive


#1

i use xpenology dsm5.2 3615sx.
rclone version is 2.44 .

If i use command at ssh, i succeed mount google drive.

It was failed when i excute from scheduler.

the message is

Fatal error: failed to mount FUSE fs: fusermount: exec: “fusermount”: executable file not found in $PATH

mount script which I use is like this
rclone mount --config /root/.config/rclone/rclone.conf --umask 0 --allow-other --allow-non-empty --read-only remoteGD:/Ani /volume1/Gdrive/Ani &

no problem with command at console through ssh.
Just i failed when execute with scheduler.


#2

Via ssh run which fusermount

then add that directory to the path in your mount script.

Eg

$ which fusermount
/bin/fusermount

Then put this in your script

export PATH=/bin:$PATH

#3

Very very Thanks!!!

Good Job!
good working!
I added path to $PATH (/usr/syno/bin/fuse ) somedays ago but it only worked in console.
So, now as your comment, I added to script on first line.

export PATH=$PATH:/usr/syno/bin/fuse

blablabla~~~

Scheduler worked.
i will add S99mount.sh to /usr/syno/etc/rc.d/ for mounting with startup.
very helpful.