Rclone mount encrypt as /local, and access from nextcloud

i installing nextcloud on my vps, and i mount my remote encrypt disk with rclone on ‘/home/user/local’

and then i add my ‘/home/user/local’ on nextcloud as external. its work to create forder and read file, but when i upload file from nextcloud to local, error like this

2018/04/17 17:41:07 ERROR : NajaTest/id_ID-v1.tar.gz.ocTransferId415749812.part: Dir.Rename error: Fs “Encrypted drive ‘NajaOwncloudFiles:/naja’” can’t rename files (no Move)

its because when i upload ‘file.zip’, its create temporary file ‘file.zip.part’, when its success, nextcloud failed to rename ‘file.zip.part’ to ‘file.gz’

my mount setting :
/usr/bin/rclone mount Remote: /home/user/local --default-permissions --uid 33 --gid 33 --umask 002 --allow-non-empty --allow-other --timeout 30s

I have access to a nextcloud and I just tried an encrypted mount and renaming a file and it worked fine.

What does your config look like for the crypt and the underlying remote?

Have you tried with the latest beta?

hi ncw, thanks for fast respon :smiley:,
my version is

rclone v1.40

  • os/arch: linux/amd64
  • go version: go1.10

type = b2
account = xxxxxxxx
key = xxxxxxxxxxxxxxx
endpoint =

type = crypt
remote = NajaVultr:NajaOwncloudFiles
filename_encryption = off
directory_name_encryption = false
password = xxxxxxxxxxxxx
password2 =

is the latert beta version rclone v1.40-086-gb8381408β? i will try

Oh, I mis-understood - I thought you were mounting the owncloud not b2.

b2 does not support server side move at the moment so can’t rename things on a mount - sorry :frowning: I can’t think of an easy way around this.

You’ll have to unpack your zip files on the filesystem before moving them into the mount.

I know there is an internal issue at b2 about this so it will get implemented eventually.

Sorry, my question is not clear :smiley: ,
ok thanks for your explanation, i will waiting for this can implement

hi ncw, i have more question, is google cloud storage or amazon s3 support rename on mount ?

Neither of those do support rename on mount yet, however they do support Server side copy so when this issue is fixed: https://github.com/ncw/rclone/issues/1965 (soon hopefully) then moves will work on mount.

thanks for your answer, i hope to its work :smiley: