Rclone mount cache directory always empty


#1

Hello all,

I am mounting my crypt directory using rclone mount and for what ever reason, the cache directory has no data in it, and it keeps polling for changes. Any uploads to it gets updated immediately and not dependent on the cache times specified.

This is my settings:

rclone mount --allow-other --cache-dir=/home/mine/cache/rclonecache --dir-cache-time 160h --drive-chunk-size 32M --fast-list --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit off --vfs-cache-mode=full remote-crypt:Learning /home/mine/mounts/decrypted_learning

The cache directory is always empty. No errors are seen when i look through a full -vvv logs.

Just a whole bunch of

2019/01/03 00:02:21 DEBUG : : >Statfs: stat={Blocks:274877906944 Bfree:268136561007 Bavail:274877906944 Files:1000000000 Ffree:1000000000 Bsize:4096 Namelen:255 Frsize:4096}, err=<nil>

2019/01/03 00:19:52 DEBUG : Google drive root 'rgt0pkt3a5m0c7akb6sgrsogbo': Checking for changes on remote

My concern comes from my understanding that, when i do a rclone move or copy, it should upload to my drive but the mounted directory should still obey the cache times and will not get invalidated would that be correct ?

Any suggestions with respect to my mount options or my understanding is welcome.


#2

I’m not quite I’m following what you are trying to do / achieve.

Are you doing a rclone copy or move to the remote? If so, that would upload or move immediately and get polled via the remote.

If you are copying or moving directly to the mount, it doesn’t look like you are using the cache backend so it would upload immediately as well.

The cache backend does delayed uploading and is documented here:

https://rclone.org/cache/#cache-tmp-wait-time

Can you explain your workflow a little more and what you are expecting to happen?


#3

Hello,
yes i am using rclone copy / move to move my data to the remote directly and not through the cache. I do not have a cache and i dont intend to do it unless i cannot achieve what i need through the mount.

Basically i need mount to be cached for 72 hours and look for updates every hour.


#4

The default for updates is 1 minute and configured via:

 --poll-interval duration             Time to wait between polling for changes. Must be smaller than dir-cache-time. Only on supported remotes. Set to 0 to disable. (default 1m0s)

The cache backend doesn’t work on time, but size unfortunately.

--vfs-cache-mode=full

Copies everything locally first before doing anything so it makes things super slow.

You probably want to use the cache backend as that gets you closer to having things for a period of time.