Rclone mount, apps not being able to access

Hello guys,

I am currently dealing with some sort of problem on the mount option in rclone. I could mount my google drive storage with no problems with this command:

rclone mount encrypt:/*** /tmp/prueba/ --vfs-cache-mode minimal

And I can go perfectly into the directly through console and list all things in that folder, but once I get my rest of apps looking there, seems to be complaining, they directly can not list whatever I have inside there.
I was trying to set 777 permissions but seems that it is staying with drwxr-xr-x not matter what chmod I write.
So I am running into no having clue on why my apps can not access the mount point.

Those anyone of you have any idea?

Kind regards

You need to add --allow-other to your mount command.

      --allow-other                            Allow access to other users.

You can also add the umask command if you want to change that as well:

      --umask int                              Override the permission bits set by the filesystem.
1 Like

Let me try with that :smiley:

Thanks for the quick reply, appreciate it much :slight_smile:

When I put --umask int in my mount script it fails. Running the command manually gives this result:

2019/11/06 04:07:05 Fatal error: invalid argument "int" for "--umask" flag: strconv.ParseInt: parsing "int": invalid syntax

Here is my rclone mount script:

#/etc/systemd/system/rclone.service
[Install]
WantedBy=default.target

[Unit]
Description=crypt (rclone)
AssertPathIsDirectory=/opt/seafile/seafile-data

[Service]
Type=simple
User=seafile
ExecStart=/usr/bin/rclone mount \
        --config=/opt/seafile/.config/rclone/rclone.conf \
        --allow-other \
        --drive-chunk-size 32M \
        --allow-non-empty \
        --transfers 16 \
        --dir-perms 0775 \
        --file-perms 0775 \
        --umask int \
        --drive-use-trash \
        --log-file=/var/log/rclone.log  crypt:Seafile /opt/seafile/seafile-data
ExecStop=/bin/fusermount -u /opt/seafile/seafile-data
Restart=always
RestartSec=10

Any ideas?

You need to put a number in for the umask. The int in the help is shorthand for place an integer here.

Typically --umask 0000 or --umask 0002 would be appropriate.

Thank you. I feel kinda dumb for not realizing that.

1 Like

What's your mount command? What version of rclone are you using?.