Rclone is removed after Synology DSM Update

so as a test, i just updated one of my synboxes, and now i cannot run rclone???!!!

root@bnas:~# rclone
-ash: rclone: command not found
root@bnas:~# which rclone
root@bnas:~#

@asdffdsa it's bizarre right?

yeah, bizarre
and it get stranger.

before i did the dsm update just now, i was running v1.57.0
i did a rclone selfupdate and the version wsa v1.58.1
then i did the dsm update

root@bnas:/# find -name rclone
./volume1/homes/user99/.config/rclone
./volume1/homes/user99/.cache/rclone
./volume1/homes/user99/rclone
./volume1/homes/user99/rclone/cache/vfs/synboxtest_remote/synboxtest/cloudsync/rclone
./volume1/homes/user99/rclone/cache/vfsMeta/synboxtest_remote/synboxtest/cloudsync/rclone
./volume1/server02files/edrive/b/data/rclone
./volume1/server02files/edrive/a/data/rclone
./volume1/@docker/btrfs/subvolumes/48377d9dccab70b8426b296db0c9ffb4db66de69b97b8f4f1600834472d4f08c/usr/local/bin/rclone
./volume1/@docker/btrfs/subvolumes/b217c15ed59f577ab3ad450259e93ed6bc43218820e218843a5e64e53e0f0631/home/rclone
./volume1/@docker/btrfs/subvolumes/b217c15ed59f577ab3ad450259e93ed6bc43218820e218843a5e64e53e0f0631/usr/local/bin/rclone
./volume1/@docker/btrfs/subvolumes/38672fec5843d2df7066b03aa7d2d3f0662d43075565847eda40a972d6ec6d5e/home/rclone
./volume1/@docker/btrfs/subvolumes/38672fec5843d2df7066b03aa7d2d3f0662d43075565847eda40a972d6ec6d5e/usr/local/bin/rclone
root@bnas:/# ./volume1/@docker/btrfs/subvolumes/48377d9dccab70b8426b296db0c9ffb4db66de69b97b8f4f1600834472d4f08c/usr/local/bin/rclone version
rclone v1.57.0
- os/version: unknown
- os/kernel: 4.4.180+ (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.17.2
- go/linking: static
- go/tags: none

@asdffdsa keep me posted if you are able to find the culprit.

rclone is a portable app, does not need to be installed.

i am going to download the executable file from here and save it to my home dir.
i have a felling that the synbox will not touch that.
and when running rclone, just hardcode the full path.

and next time I need to update a synbox, I will see what happens.

you might try the same, and see what happens.

@asdffdsa how/where do you hardcode the full path?

this is what i did

  1. copied the rclone executable into /var/services/homes/user99/rclone
  2. chmod +X /var/services/homes/user99/rclone/rclone
  3. in my homedir, created a file named .profile and added the following text
user99@bnas:~$ cat ~/.profile
PATH=/var/services/homes/user99/rclone:$PATH
export PATH
  1. logout
  2. login
  3. to check if that worked
user99@bnas:~$ which rclone
/var/services/homes/user99/rclone/rclone

user99@bnas:~$ rclone version
rclone v1.58.1
- os/version: unknown
- os/kernel: 4.4.180+ (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.17.9
- go/linking: static
- go/tags: none

@asdffdsa when I type "which rclone" I get "/bin/rclone" is that correct? If not, what am I doing wrong? I did your aboved mention steps in my user home folder and not in root.

after the dsm update, did you reinstall rclone using the install script?
curl https://rclone.org/install.sh | sudo bash

@asdffdsa yes I did.

so now you are back to where you were before, next time dsm does an update, rclone will be lost.

@asdffdsa so removing the current install and setting it up the way you mentioned should do the trick correct?

all i know is that dsm updates remove rclone.

i believe my solution is a workaround for that as dsm update is not going to mess up my home dir.
the only way to know, for sure, is the next time one of my synboxes needs a dsm update.

@asdffdsa I'm curious if this fixes the issue.

me too.

for now, just have to wait for the next dsm update.
i will try to remember to update this topic then.

@asdffdsa sorry for all the questions. I went in and removed rclone and when I I run the chmod +X command it doesn't install rclone. But, I don't receive an issue message either (for example, the file does exist.)

What am I doing wrong? Just to be clear I am only putting the executable file in user reclone folder.

please understand that i cannot see into your machine.

need to follow the steps i outlined above.

install entware, instructions can be found on the GitHub page;

so you can install rclone with

benba@nas:~$ sudo opkg update
Password: 
Downloading http://bin.entware.net/x64-k3.2/Packages.gz
Updated list of available packages in /opt/var/opkg-lists/entware
benba@nas:~$ sudo opkg install rclone
Package rclone (1.58.0-1) installed in root is up to date.
benba@nas:~$ which rclone
/opt/bin/rclone
benba@nas:~$ 


I never had any issues when there was an dsm update. I also updated my dsm from version 6 to 7 without any issues for entware or rclone.

ps: i use entware on my synology nas since may 2018...

hi,
can you post the output of rclone version?

Mine also stopped working after DSM update but after reinstalling RClone it is working normally now