Rclone from Synology to cloud storage

What is the problem you are having with rclone?

I have made a config on my NAS (synology)

Remote: remotejotta

device = Jotta
mountpoint = Archive
username = modesty

I need help to understand the rsync options

I will bacup all files on Volume1 (in storage pool 1 (i have only one) to Jotta Archive

What is your rclone version (output from rclone version)

rclone v1.56.2

  • os/version: unknown
  • os/kernel: 4.4.180+ (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.16.8
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Jotta

The command you were trying to run (eg rclone copy /tmp remote:tmp)

I have not made a command, totaly not shure what to do to backup my NAS to Jotta

rclone something like this
rclone Volume1:Jotta Archive

this command will run as a cron job (not configured yet)

The rclone config contents with secrets removed.

Im not familiar with SSH putty to linux so I dont know ow to find it and copy it

A log from the command with the -vv flag

No log per today

hello,

is this a one time backup or a backup you will run on a schedule?

rclone sync -v /volume1 remotejotta:

if you want to a forever forward incremental backup
https://rclone.org/docs/#backup-dir-dir

rclone sync  -v /volume1 remotejotta:current remotejotta:archive/`date +%Y%m%d.%I%M%S`

Thanks @asdffdsa

this one worked as a normal copy job :slight_smile:

rclone sync -v /volume1 remotejotta:

The one you suggested, a perfect suggestion by the way, a incremental backup job, did not kick in, probably syntax with the ' sign
Any Idea what to change?

clone sync -v /volume1 remotejotta:current remotejotta:archive/`date +%Y%m%d.%I%M%S

Result:

Usage:
rclone sync source:path dest:path [flags]

Flags:
--create-empty-src-dirs Create empty source dirs on destination after sync
-h, --help help for sync

Use "rclone [command] --help" for more information about a command.
Use "rclone help flags" for to see the global flags.
Use "rclone help backends" for a list of supported services.
Command sync needs 2 arguments maximum: you provided 3 non flag arguments: ["/volume1" "remotejotta:current" "remotejotta:archive/20211003.073 220"]

--backup-dir

rclone sync -i /path/to/local remote:current --backup-dir remote:old

sorry, there was a problem with the command i posted.

rclone sync -i /path/to/local remote:current --backup-dir remote:old
that will keep only a single older version.

if you want to keep multiple older versions then use something like this

rclone sync /path/to/local remote:current --backup-dir=remote:archive/`date +%Y%m%d.%I%M%S` -vv --dry-run 

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.