Rclone fatal error: out of memory

What is the problem you are having with rclone?

runtime: VirtualAlloc of 1048576 bytes failed with errno=1455
fatal error: out of memory

What is your rclone version (output from rclone version)

rclone v1.50.1

  • os/arch: windows/amd64
  • go version: go1.13.4

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10, 64 bit

Which cloud storage system are you using? (eg Google Drive)

Google Drive (Shared drive of a G Suite)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount series: O: --cache-dir c:\rclone-cache --allow-other --buffer-size 1G --drive-chunk-size 32M --fast-list --vfs-cache-mode writes --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit off --log-level ERROR --log-file c:\rclone\rclone_mount.log#### A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

I am running rclone on a i7-7600U computer with 2x8GB RAM which I mainly use as Plex Media Server. The OS is installed on an external SSD connected to the computer via SATA-USB3.0 adapter.
When scanning large media libraries (i.e TV Shows), the dedicated remote for TV Shows suddenly gets disconnected (the other remotes are not affected).
If I do the same library scanning with a remote mounted with RaiDrive, everything just works fine, so I am wondering if the problem is with rclone, the command I am using or something else..?

Thank you in advance for your kind help. I would really like to keep using rclone instead of RaiDrive as the performance when streaming content is so much better.

Partial copy&paste from the log (if needed I can paste more details)
runtime stack:
runtime.throw(0x16dab14, 0xd)
C:/hostedtoolcache/windows/go/1.13.4/x64/src/runtime/panic.go:774 +0x79
runtime.sysUsed(0xc290e4a000, 0x100000)
C:/hostedtoolcache/windows/go/1.13.4/x64/src/runtime/mem_windows.go:83 +0x230
runtime.(*mheap).allocSpanLocked(0x23e17a0, 0x80, 0x23fec68, 0xc006368850)
C:/hostedtoolcache/windows/go/1.13.4/x64/src/runtime/mheap.go:1228 +0x203
runtime.(*mheap).alloc_m(0x23e17a0, 0x80, 0x101, 0x0)
C:/hostedtoolcache/windows/go/1.13.4/x64/src/runtime/mheap.go:1022 +0xd0
runtime.(*mheap).alloc.func1()
C:/hostedtoolcache/windows/go/1.13.4/x64/src/runtime/mheap.go:1093 +0x53
runtime.(*mheap).alloc(0x23e17a0, 0x80, 0x25010101, 0x42a667)
C:/hostedtoolcache/windows/go/1.13.4/x64/src/runtime/mheap.go:1092 +0x91
runtime.largeAlloc(0x100000, 0x450101, 0xc290d4a000)
C:/hostedtoolcache/windows/go/1.13.4/x64/src/runtime/malloc.go:1138 +0x9e
runtime.mallocgc.func1()
C:/hostedtoolcache/windows/go/1.13.4/x64/src/runtime/malloc.go:1033 +0x4d
runtime.systemstack(0x16a250)
C:/hostedtoolcache/windows/go/1.13.4/x64/src/runtime/asm_amd64.s:370 +0x6b
runtime.mstart()
C:/hostedtoolcache/windows/go/1.13.4/x64/src/runtime/proc.go:1146![image|184x500]

Rclone will be using 1G for each open file with this setting which will run you out of memory quite quickly!

I suggest setting it much smaller - the default is 16M which works pretty well for most applications.

Thanks for the answer, I’ll try your suggestion during the coming days and I’ll revert back with the results