Rclone failed to sync Versions file

Hi all,

Im using rclone v1.6.7 on Redhat8
My S3 Endpoint is Ceph

My issues is: when we use
$ rclone ls myconfig:bucketname....-> it worked, list all VERSIONING file
but when we run
$ rclone sync myconfig:bucketname....-> not worked with my VERSIONING file

rclone can see this file but cannot copy them. Could anyone help me explain this ?

Thank you all.

rclone ls ceph-agency:agency-prod/Uploads/BVDPUploads/BVDP
521492 2024_01_16/ATS/HD_ATS_AG.ATS.24.848_20240116_084431.pdf
521465 2024_01_16/ATS/HD_ATS_AG.ATS.24.849_20240116_084831.pdf

rclone copy ceph-agency:agency-prod/Uploads/BVDPUploads/BVDP/* /s3syn/ -P -v --s3-versions
2024/07/11 10:00:27 INFO : There was nothing to transfer
Transferred: 0 B / 0 B, -, 0 B/s, ETA -
Elapsed time: 0.4s
2024/07/11 10:00:27 INFO :
Transferred: 0 B / 0 B, -, 0 B/s, ETA -
Elapsed time: 0.4s

My config file:

[ceph-agency]
type = s3
provider = Ceph
access_key_id = XXXXXXXXXXXXXXX
secret_access_key = XXXXXXXXXXXX
region =
location_constraint =
acl =
server_side_encryption =
storage_class =
env_auth = false
endpoint = XXXX

You can NOT copy/sync S3 files with versions with rclone.

Using rclone only, what you could do is to copy bucket multiple times using --s3-version-at flag in source bucket config definition.

Assuming that your destination bucket supports versions they will be created again (but you will lose versions timestamp). So it is very crude approach. Would try it only if really no other option.

I think you should investigate some other tools like aws-cli (or whatever ceph provides).

Thank you so much, I will try another way

1 Like

And if you find working solution it would be great if you share it with us:) Definitely something many people would like to know.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.