Rclone drive sets up a new directory other than my user one

Hey all,

I tried setting up rclone with my own client ID, secret, and service account. I can upload a file up to it, but it has created a totally new directory (not using my user’s directory) and I’m not sure where it’s coming from. I tried to rclone ls and it shows only a Getting Started doc and the file I rclone copy up to it. Anyone have this issue before?


If you type:

rclone config show

and share the output (removing all personal keys and such), we can figure it out.

Thanks! I actually tried to do a impersonate test and it looks like I’m not authorized. I’ll try to figure out why I’m not authorized…

Error I get

2018/08/31 09:31:25 ERROR : : error listing: couldn't list directory: Get https://www.googleapis.com/drive/v3/files?alt=json&fields=files%28id%2Cname%2Csize%2Cmd5Checksum%2Ctrashed%2CmodifiedTime%2CcreatedTime%2CmimeType%29%2CnextPageToken&pageSize=1000&q=trashed%3Dfalse+and+%271KWM2MdgUY0xowJdK9-XYb73jlz5NMHuQ%27+in+parents: oauth2: cannot fetch token: 401 Unauthorized Response: { "error": "unauthorized_client", "error_description": "Client is unauthorized to retrieve access tokens using this method." }

You should be able to take the .rclone.conf and drop it from one machine to another.

You can copy and paste the drive section out as well if you want to try that.

It should work without issue as I’ve done that many, many times.

Thanks! It was user error… I scoped the wrong account. Works now!

1 Like