Rclone doesnt mount. Or mounts once and then does not rem

quick look:
Failed to copy: 1 error: Dropbox_1: path/no_write_permission/
perhaps rclone is retrying to upload files over and over again.

let's see what @Animosity022 think about that log

yeah, you are correct; i had a brain fart.
i had read a post from ncw and i had read the PR, but somehow, depsite that, i posted it wrong.

yes I know the one folder is read only. It has always been that way. why does that matter? I dont need to write to it.
But I have write permission set for the other folder the plex_personal
The plex folder does not have write permission.
The weird thing is nothing has changed. I have used the mount the server company recommended

screen -dm rclone mount --buffer-size=32M --dir-cache-time=84h --vfs-cache-mode=minimal --vfs-cache-max-age=6h remote: ~/mount/

Then Kapitanisky gave me some ideas on mounting with a higher cache and the mount that was at the start of this thread

maybe it does not matter, but rclone considers it an error and will retry.

imho, the cache is corrupt and full of errors.
why not just start the mount with a new empty clean cache dir location using --cache-dir

when you first posted, you where using --vfs-cache-mode full

What do you mean a clean cache directory? Like a whole new folder? if I change the mount folder then everything in my library will have to be rescanned


i agree, do not change the mount folder, no need for that.

i am suggesting to start with a new empty clean cache.
--cache-dir string Directory rclone will use for caching.

how would I do a read only dropbox union mount? Because emby doesnt need to write to anything I just need it to read. That would fix the error

very common, to have a read-only mount and rclone has a handy flag for that.
--read-only Only allow read-only access

Yes I thought changing this might help

i think these should work well for streaming, somthing like this
--vfs-cache-mode=full --read-only --cache-dir=~/cachefolder

and when using --read-only, technically, no need for file cache.

for example, i have a media server running on cheap hetzner vm and store media on hetzner storagebox.
so for that, no need for file cache.
basically, i am using --read-only --vfs-cache-mode=off

I am. using whatbox server. but my content is stored on dropbox.

screen -dm rclone mount --dir-cache-time 9999h --vfs-cache-mode full --read-only --cache-dir= ~/test  Dropbox1:/ ~/mountedfolder --log-level DEBUG --log-file ~/rclone.log

this didn't mount so what did I do wrong

well, you did not post the debug log???
make sure to delete rclone.log each time, before running the command.

rclone-4.log (6.0 KB)

--cache-dir ~/test

using this command still tries writing and still doesnt mount.
rclone.log (583.2 KB)

screen -dm rclone mount --dir-cache-time 9999h --vfs-cache-mode full --read-only Dropbox1:/ ~/mountedfolder --log-level DEBUG --log-file ~/rclone.log

well, you are using the same old cache, so you still have the same old problems.

and you can tell that for yourself by looking at the log
vfs cache: root is "/home/ilovemymac/.cache/rclone"

and please, delete the old rclone.log each time, get confusing, ok?

so use --cache-dir
if it is easier, then just delete all the files in the current cache dir, and start over with a clean, empty, not corrupted cache.

the root of all caches for all rclone mounts is at
vfs cache: root is "/home/ilovemymac/.cache/rclone"

the caches for your current mount is at
vfs cache: data root is "/home/ilovemymac/.cache/rclone/vfs/Dropbox1"
vfs cache: metadata root is "/home/ilovemymac/.cache/rclone/vfsMeta/Dropbox1"

So I can delete the old cache with no harm to emby? I had read somewhere in the rclone forum about someone warning against cleaning cache
But I am doing to do that now.

yes, that is correct.

1 Like

Thank you for your help. It was driving me crazy. But I am learning so that I can keep up with stuff. It was just so weird that up till recently rclone just always mounted so wasn't sure what had happened.

so the mount is working now?

1 Like