Rclone docker not creating the .conf file

Hi, this is my compose
rclone: image: hotio/rclone hostname: ${DOCKERHOSTNAME} container_name: rclone environment: - RCLONE_CONFIG=/config/rclone.conf security_opt: - apparmor:unconfined cap_add: - SYS_ADMIN devices: - /dev/fuse logging: driver: json-file options: max-file: ${DOCKERLOGGING_MAXFILE} max-size: ${DOCKERLOGGING_MAXSIZE} restart: unless-stopped volumes: - /mnt/gdrive:/mnt/gdrive:shared - ${DOCKERCONFDIR}/rclone:/config command: mount "gdrive:" "/mnt/gdrive" --allow-other --uid "1000" --gid "1000" --umask "022"

And when I run this to create a .conf docker run --rm -it -v ${DOCKERCONFDIR}/rclone:/config -e RCLONE_CONFIG=/config/rclone.conf hotio/rclone config

The file creates in the root location /rclone/rclone.conf instead of ${DOCKERCONFDIR}/rclone:/config

My friend mentioned that ${DOCKERCONFDIR} is not set. I am still not getting :frowning:

Thank you

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.