Rclone directory sync error

I am trying to sync my directory from headless ubuntu18 via terminal to mega but the process fails.

I can't give you -vv log error it's too huge. My single file transfer works well with mega.

I use " sudo rclone copy /path/directory mega:" also i tried changing copy to sync still everything fails.

Can you post some error messages?

What version of rclone are you using? Can you try the latest beta?

this is my log https://pastebin.com/bBdfnVFs

I have tried using "rclone copy" and "rclone sync" still I am facing same issue. I have tried using / at end of folder and even while removing / at end. still getting same error.

Looks like you ran out of memory on the server. Is it a small memory instance or something?

Yeah a 512 mb ram. But I can do individual uploads for even big files like 10gb plus. Is that error stands for memory? I am trying to upload 3gb of season folder.

You could try to limit the number of transfers by using --transfers 1 and you can use --nmap to reduce memory usage and --buffer-size 0M to turn that off as well and you can turn --checkers 1.

With only 512MB, you are probably fighting with other programs and by default it does 4 transfers and 8 checkers so that uses a bit of memory too.

That's just genius. That's working for me. Awesome.

The only thing --nmap is not logged as "unknown error flag --nmap".

How to use --nmap. I am suppose to add some value?

Sorry my bad:

 --use-mmap                             Use mmap allocator (see docs).

instead of what I had above.

Well thanks a ton

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.