Rclone copy is extremely slow

might try

* disable ipv6 and test
* have rclone bind to a ipv4 address using [https://rclone.org/docs/#bind-string ](https://rclone.org/docs/#bind-string)

Yes, I've got a 10Gbpe NIC.
US. Google Enterprise Suite (I'm not sure it's US o rnot).

I've binded to the local IP of the PC, and disable IPv6.
Nothing changes, capped at 35MB/s.

ok, at least we are eliminating all the solutions that worked for other rcloners.

1 Like


  --disable-http2   Disable HTTP/2 in the global transport

I don't think this will make a difference for drive since we disable it in the drive backend by default, but maybe that isn't working for some reason.

hi, yesterday, i tested a few times, did not make a difference; so i did not post the results.


I guess there must be some code change, to utilize the 5Gbps Fiber network speed. Currently, my workaround is using IDM, and usually download at over 300MB per second, so fluctuate to around nearly 1TB per hour. Currently, it will meet the limit 10TB per day of Google Drive. Not too bad, though I must do the download manually, instead of delegating all to Rclone.

I'll just note it is taking 11 seconds to verify the MD5 sum...

If you add

  --ignore-checksum   Skip post copy check of checksums

I expect it will run a lot faster.

I've tried this:

rclone copy GDrive:X.mp4 U: --progress --log-level=DEBUG --log-file=rclone.log --stats=5h --multi-thread-streams=8 --disable-http2 --ignore-checksum

At the beginning the speed raised up to around 44MBps, but then it turned back to 30ish MBps.

So nothing's special with the new param.

What kind of disk is U:? Is it an HDD? Try --multi-thread-streams=0 and see if that make a difference.

It's an HDD in a NAS.
I've tried --multi-thread-streams=0, and nothing's different.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.