Rclone copy gdrive slowing down after few minutes

Hello everyone,
I read 3-4 other posts with same problems but it doesn't solve my case

What is the problem you are having with rclone?

I have a 1Gbps connection so I can download up to ~120MB/s tried/verified with multiple servers. First minute of my rclone copy, I can download up to 110MB/s thereupon the speed slowing down to to stabilize arount 75MB/s

As you can see here
i [dot] imgur [dot] com/6CzPqM8.png

What is your rclone version

rclone v1.52.0-001-g1cceadaf-beta
already tried rclone, rclone beta

Which OS you are using and how many bits


Which cloud storage system are you using?

Google Drive Team Drive with service account file.
Crypt remote.

The command you were trying to run

rclone copy gdrive_crypt:folder /mnt/user/folder -P
already tried these options :

The rclone config contents with secrets removed.

type = drive
scope = drive
service_account_file = /mnt/user/appdata/xxx.json
team_drive = xxxx

type = crypt
remote = gdrive:enc
filename_encryption = standard
directory_name_encryption = true
password =
password2 =

Do you have any suggestion ?

thank you

About the only thing you can tweak is transfers and drive-chunk-size. Are you transferring small and large files? If you're transferring both the it takes to switch files on smaller ones well pull down the average. You can also play with the multithreaded options and increase the number of threads if you're downloading large files but only a few.

Only large files >4GB

already tried transfers=10 or 20 or 2. in each test, stabilization around 75-80MB/s.

Already tried --drive-chunk-size 256M (i have 32GB RAM).

I don't tried multithreaded options, i will try and come back with results.

Thank you

For a gigabit connection, that's not too bad.

I use defaults on everything and only add a chunk size of 1024M and get a little better.

Transferred:   	  225.894G / 225.894 GBytes, 100%, 87.115 MBytes/s, ETA 0s
Transferred:   	   52.503G / 52.503 GBytes, 100%, 85.592 MBytes/s, ETA 0s
Transferred:   	  199.713G / 199.713 GBytes, 100%, 90.489 MBytes/s, ETA 0s
Transferred:   	    9.881G / 9.881 GBytes, 100%, 87.609 MBytes/s, ETA 0s

I tried --multi-thread-cutoff=1G --drive-chunk-size=1024M, same problem : stabilization around 75-80MB/s.

The most frustrating thing is that I can upload with rclone a large amount of large files at 100MB/s in a very stable way without any worries.

Unfortunately, that might be the best you can do with your setup as that's doing quite well.

The only things left to tune are what you cannot change which is your peering along your network.

If you've ruled out everything on your side, CPU, memory, disk and your own router/network, that might be it.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.