Rclone copy does not stop uploading the files again and again

#1

Good morning, first of all I’m using the translator, I’m sorry if you do not understand everything well.

I download a torrent, and I have the completed downloads uploaded to a mega account and google drive with the following commands:

rclone copy / home / downloads googledrive: anime / -v --no-traverse --log-file = / home = / home / rclone-upload.log

rclone copy / home / mega downloads: anime / -v --no-traverse --log-file = / home / rclone / rclone-uploadmega.log

In google drive it goes up without any problem.

But in mega, the files are raised without stopping until it reaches the limit of GB of account limitation (50gb)

What can I do to have the files uploaded only once?

0 Likes

#2

I’m guessing because mega doesn’t support checksum. What happens if you specify “size-only” on mega?

0 Likes

#3

Hello, thanks for your answer, could you give me an example of the command that would be? I’m a little lost

0 Likes

#4

I was thinking this may do it. It will ignore times and use size to determine it.

rclone copy /home/mega downloads:anime/ -v --no-traverse --log-file=/home/rclone/rclone-uploadmega.log --size-only

0 Likes

#5

It does not work, unfortunately it keeps uploading the files without stopping until the capacity is full

0 Likes

#6

A debug log might help. -vv

0 Likes

#7

thx for you help!

this is a log for mega (the log has many lines)

https://mega.nz/#!O1NTAYAY!11mbJiqjA_wI3L0UoTZObB-Dfw-mfF9wqAFSYCMqMYw

0 Likes

#8

I think that is only a info level log. A debug would give the reasons why it was re-uploaded. -vv

0 Likes

#9

What would be the command to debug?

Thank you for your patience

0 Likes

#10

You can run with -vv

0 Likes

#11

rclone copy /home/mega downloads:anime/ -v --no-traverse --log-file=/home/rclone/rclone-uploadmega.log --vv

or

rclone -vv

thx!

0 Likes

#12

First one is fine as it doesn’t matter really where the switch is.

0 Likes

#13

thank you, now I will do the test

0 Likes

#14

is same?

https://pastebin.com/b94EBvvR

0 Likes

#15

You aren’t using “–size-only”.

Perhaps try one file and recopy it and see what the debug log says.

0 Likes

#16

Hmm. I would have expected more debug info. What happens if you run a rclone check?

Rclone check /local remote: --one-way

Rclone check /local remote: --one-way --size-only

after the files are uploaded.

0 Likes

#17

There is also a

--mega-debug

Flag. I’ve not much experience with mega but maybe it’ll help bring some more info.

“where all files are encrypted locally before they are uploaded.”

If there is a encryption happening and the files use a salt I bet your issue will be resolved by using the size-only flag.

0 Likes

#18

root@ns376896:/home# rclone check /home/cuentasmega/mega29 mega: --one-way
2019/04/06 15:33:08 NOTICE: mega root ‘’: 0 differences found
2019/04/06 15:33:08 NOTICE: mega root ‘’: 140 hashes could not be checked
2019/04/06 15:33:08 NOTICE: mega root ‘’: 140 matching files
root@ns376896:/home#

root@ns376896:/home# rclone check /home/cuentasmega/mega29 mega: --one-way --size-only
2019/04/06 15:34:01 NOTICE: mega root ‘’: 0 differences found
2019/04/06 15:34:01 NOTICE: mega root ‘’: 140 matching files
root@ns376896:/home#

0 Likes

#19

rclone copy /home/descargas mega:anime/ --mega-debug -v --no-traverse --log-file=/home/rclone-uploadmega.log

Would that be the command?

0 Likes

#20

No need. I’d say it’s checking hashes and those are different. So you need --size-only on mega.

0 Likes