Rclone config fails oAuth - google response unverified app

What is the problem you are having with rclone?

trying to run "rclone config" on raspberry pi 4 using latest update
create new google credential - provided client id and secret.
waiting for google response in browser; browser response says
unverified credential. configuration never ends (just waiting).

Run the command 'rclone version' and share the full output of the command.

rclone v1.53.3-DEV

  • os/arch: linux/arm64
  • go version: go1.15.9

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

   rclone config 

The rclone config contents with secrets removed.

rclone config

A log from the command with the -vv flag

Ran "rclone -vv config" - you don't tell me where to find the required log data, there are too many. be more specific. (a path the the linux dir would be a start. 

copy of screen output (edited to remove security info :

rclone -vv config
2022/09/22 20:25:33 DEBUG : rclone: Version "v1.53.3-DEV" starting with parameters ["rclone" "-vv" "config"]
2022/09/22 20:25:33 NOTICE: Config file "/home/crossettpi/.config/rclone/rclone.conf" not found - using defaults
No remotes found - make a new one
n) New remote
s) Set configuration password
q) Quit config
n/s/q> n
name> gDive
Type of storage to configure.
Enter a string value. Press Enter for the default ("").
Choose a number from below, or type in your own value
 1 / 1Fichier
   \ "fichier"
 2 / Alias for an existing remote
   \ "alias"
 3 / Amazon Drive
   \ "amazon cloud drive"
 4 / Amazon S3 Compliant Storage Provider (AWS, Alibaba, Ceph, Digital Ocean, Dreamhost, IBM COS, Minio, Tencent COS, etc)
   \ "s3"
 5 / Backblaze B2
   \ "b2"
 6 / Box
   \ "box"
 7 / Cache a remote
   \ "cache"
 8 / Citrix Sharefile
   \ "sharefile"
 9 / Dropbox
   \ "dropbox"
10 / Encrypt/Decrypt a remote
   \ "crypt"
11 / FTP Connection
   \ "ftp"
12 / Google Cloud Storage (this is not Google Drive)
   \ "google cloud storage"
13 / Google Drive
   \ "drive"
14 / Google Photos
   \ "google photos"
15 / Hubic
   \ "hubic"
16 / In memory object storage system.
   \ "memory"
17 / Jottacloud
   \ "jottacloud"
18 / Koofr
   \ "koofr"
19 / Local Disk
   \ "local"
20 / Mail.ru Cloud
   \ "mailru"
21 / Microsoft Azure Blob Storage
   \ "azureblob"
22 / Microsoft OneDrive
   \ "onedrive"
23 / OpenDrive
   \ "opendrive"
24 / OpenStack Swift (Rackspace Cloud Files, Memset Memstore, OVH)
   \ "swift"
25 / Pcloud
   \ "pcloud"
26 / Put.io
   \ "putio"
27 / SSH/SFTP Connection
   \ "sftp"
28 / Sugarsync
   \ "sugarsync"
29 / Transparently chunk/split large files
   \ "chunker"
30 / Union merges the contents of several upstream fs
   \ "union"
31 / Webdav
   \ "webdav"
32 / Yandex Disk
   \ "yandex"
33 / http Connection
   \ "http"
34 / premiumize.me
   \ "premiumizeme"
35 / seafile
   \ "seafile"
Storage> 13
** See help for drive backend at: https://rclone.org/drive/ **

Google Application Client Id
Setting your own is recommended.
See https://rclone.org/drive/#making-your-own-client-id for how to create your own.
If you leave this blank, it will use an internal key which is low performance.
Enter a string value. Press Enter for the default ("").
client_id> 344002............
OAuth Client Secret   
Leave blank normally.
Enter a string value. Press Enter for the default ("").
client_secret> G...................................
Scope that rclone should use when requesting access from drive.
Enter a string value. Press Enter for the default ("").
Choose a number from below, or type in your own value
 1 / Full access all files, excluding Application Data Folder.
   \ "drive"
 2 / Read-only access to file metadata and file contents.
   \ "drive.readonly"
   / Access to files created by rclone only.
 3 | These are visible in the drive website.
 
 is revoked when the user deauthorizes the app.
   \ "drive.file"
   / Allows read and write access to the Application Data folder.
 4 | This is not visible in the drive website.
   \ "drive.appfolder"
   / Allows read-only access to file metadata but
 5 | does not allow any access to read or download file content.
   \ "drive.metadata.readonly"
scope> 1
ID of the root folder
Leave blank normally.

Fill in to access "Computers" folders (see docs), or for rclone to use
a non root folder as its starting point.

Enter a string value. Press Enter for the default ("").
root_folder_id> 
Service Account Credentials JSON file path 
Leave blank normally.
Needed only if you want use SA instead of interactive login.

Leading `~` will be expanded in the file name as will environment variables such as `${RCLONE_CONFIG_DIR}`.

Enter a string value. Press Enter for the default ("").
service_account_file> 
Edit advanced config? (y/n)
y) Yes
n) No (default)
y/n> 
Remote config
Use auto config?
 * Say Y if not sure
 * Say N if you are working on a remote or headless machine
y) Yes (default)
n) No
y/n> 
2022/09/22 20:26:30 DEBUG : Starting auth server on 127.0.0.1:53682
If your browser doesn't open automatically go to the following link: http://127.0.0.1:53682/auth?state=jHegR6N4h2dsfx4Opvvtnw
Log in and authorize rclone for access
Waiting for code...
^Z
[1]+  Stopped                 rclone -vv config
crossettpi@extra1:~ $ 
 
browser response both by waiting (browser opened automaticly)
and copied in the URL you provided - was the same - unverified app

In searching for a solution I follow a simple two step process
(was trying to use rsync) but was lead to rclone.
Did rclone install and then rclone config.

After it failed did more research and found out about creating
certification via google console.

However, this process has seemed to change since that documentation
was written. Did the best to follow it. Created first credential, but
noticed it was marked (internal). fumbled my way through the steps
and got an "external" type of credential. published it but still no change

Any help is appreciated.

Reading the console interaction, I noticed that an AUTH server is mentioned. No mention was the requirement for an LDAP server.
It does not come preinstalled in the basic raspberry pi config.

Looking into this

Update the version as that old one won’t work.

I just ran "rclone selfupdate" but my current version says that is an invalid option.

I am running the latest raspberry pi OS on a fresh install from the raspberry pi website.

I did "sudo apt install rclone" and this is the version that was installed.

runnnig apt update; upgrade does not change anything.

searched and found documentation for installing the latest version from the rclone.org

The instructions refer to an AMD type cpu , but raspberry pi is an ARM (broadcom) device. Consequently When I tried to run "rclone config"
after copying the new version to /usr/bin

I received the following responses


crossettpi@extra1:~ $ rclone selfupdate
bash: /usr/bin/rclone: cannot execute binary file: Exec format error
crossettpi@extra1:~ $ sudo rclone selfupdate
/usr/bin/rclone: 1: Syntax error: "(" unexpected
crossettpi@extra1:~ $ rclone config
bash: /usr/bin/rclone: cannot execute binary file: Exec format error


Install directions are here

Most package managers won’t work. You can’t use self update as that version is years old.

you are correct. I updated my previous response after going to rclone.org
and following the linux install process.

As I stated above. I believe the version is for AMD type cpu and raspberry pi is an ARM (broadcom) cpu.

How ever, I did find another website that probably is for older versions.
It specifies: not to include client id and secret but then specifies a manual setup rather than auto setup. This seemed to work. At least I have a drive definition in .config/rclone. directory.


Setup Rclone with Google Drive using SSH - seedit4.me

Further testing is needed to see if it works.

Well I found another install process on the Raspberry pi website.

I installed the ARM version (at least it seems to run). And I did a
rclone selfupdate and it reports the latest version as

rclone v1.59.2

  • os/version: raspbian 11.5 (64 bit)
  • os/kernel: 5.15.61-v8+ (aarch64)
  • os/type: linux
  • os/arch: arm
  • go/version: go1.18.6
  • go/linking: static
  • go/tags: none

However I tried to run the config process using the client id and secret and an auto config (by default).

This time a received a message from drop box that states"

Error (400)

It seems the app you were using submitted a bad request. If you would like to report this error to the app's developer, include the information below.

--

the client id is the correct value.

Ok so now I receive an similar "404" error from dropbook saying the same thing. I will go back to the origional rclone from rpi and the manual config to see if it works

Are you using Dropbox or Google Drive?