Rclone compatibility with Android app encryption?

Hey All,

I was not sure how to phrase the subject but basically, I've been using rclone to for multiple backup/sync:

Google Photos -> S3
Google Drive -> S3
NAS -> S3
And Sync S3 <-> NAS for all the Google Stuff in S3

Basically backing my Google Photos up to S3 and then down to the NAS. Looking for another way to push data from Android to S3 encrypted... and then pull it down from S3 to my local NAS using rclone.

Basically to get rid of the Google Photo backup functionality.

Next Cloud seems like a great option but I'm still not comfortable enough with reverse proxy and opening up my network..

Any help, ideas, thoughts would be greatly appreciated!

Merry Christmas and here's to a great 2020 :smiley:



You can run rclone from termux on android so you could use that as part of a solution.

pkg install rclone

Then you'll find your photos in storage/dcim/Camera

So you can run a script like this

# backup photos


rclone sync --fast-list --exclude ".thumbnails/**" -P ~/storage/dcim ${DEST}/current --backup-dir ${DEST}/$(date +%Y-%m-%d-%H%M%S)

You can then run that via termux:boot using the termux job scheduler

Contents of .termux/boot/rclone.sh

# every 4 hours if on wifi and charging, run backup
termux-job-scheduler -s ~/bin/backup.sh --period-ms 14400000 --network unmetered --charging true

Thanks Nick! I tested rclone on Termux and it worked fine... seemed a little cumbersome :slight_smile:

However, that "cron" line is perfect! who'd a thunk it .... on Wifi and charging ...

Thanks! Happy New Year!

1 Like

wow this is fantastic, rclone on android.
and it was easy to get done.

  1. install termux
  2. setup sshd
  3. install ZORK - because i always install ZORK first, greatest game of all time.
  4. install rclone.

but i am having a basic linux issue, as i am windows user.

i am trying to write a basic .sh script, my problem is passing rclone password to a script
here is what i am trying and each time i run it, rclone will ask for the config password.

rclone lsd wasabieast2:

so what am i doing wrong

All that stuff should be in your rclone.conf file .. for termux it should be in ~/.config/rclone/rclone.conf
Once you run rclone config

Here's one of the entries in my rclone.conf file

type = s3
provider = Wasabi
env_auth = false
access_key_id = XXX
secret_access_key = XXX
region =
endpoint = s3.wasabisys.com
location_constraint =
acl = private

Hope that helps

thanks but let me clarify.

i am a long time user and i already have a good rclone.conf.
the rclone.conf is password protected.
i need to pass the rclone password to the executable rclone.

on windows i would do

rclone command

i need to know how to do that on linux?


you need to delete that post, as you have included access_key_id and secret_access_key .
please delete that post ASAP

EDIT: i just communicated with @kebuchan and i was told that the keys are gibberish.

That is fine, except it should be RCLONE_CONFIG_PASS

sorry, i missed that.

@kebuchan FYI

There is also some work being done to support this in the app over at https://github.com/x0b/rcloneExplorer/pull/37, to make this a lot more user-friendly, and it should land in the app - soon™.