Rclone cache-tmp-wait-time not being honored


#1

Ubuntu 16.04 LTS (fresh install today)
rclone v1.46 (fresh install today)

Issue
My understanding is that new files/directories copied/moved/created in the cache location will wait for the determined time period I have set (60 minutes in my case). Instead, files/folders are being immediately created in my Google Drive. I have tried varying mount commands. I have also tried adjusting the advanced config in rclone cache to enter my tmp-path and tmp-wait-time there as opposed to the mount command. All ended with the same result.

Rclone config
[gsuite]
type = drive
scope = drive
token = {token}

[gcache]
type = cache
remote = gsuite:
chunk_size = 10M
info_age = 2d
chunk_total_size = 32G

Mount Command
/usr/bin/rclone mount gcache: /home/brian/media --allow-other --dir-cache-time=36h --cache-chunk-size=10M --cache-info-age=48h --cache-workers=5 --cache-tmp-upload-path /home/brian/rclone_upload --cache-tmp-wait-time=60m --umask 002 --log-file /home/brian/rclone.log --rc --log-level DEBUG

Log File
Pastebin Log


#2

Where do you think the error is happening in that log?


#3

I truly don’t know where in the log. But if I login to my Google Drive account immediately after creating that directory and moving it to my rclone cache, the directory (in Google Drive) is immediately created. I would expect it to be delayed 60 minutes.


#4

The directory in question is located at Unencrypted/TV Shows/test_18_27/

Sorry for not including that info. That directory was aptly named for the time in which it was created. As you can see from the log time stamp, it immediately uploaded.


#5

Oh, I think I see the confusion.

Directories are not files. Directories are created immediately as nothing is uploaded for them.

I’m pretty sure the wait is just for files. You can test that as you’ll see the upload in the logs.


#6

So the plot thickens now - -

I threw a test file in a newly created directory and attempted to test that.

My process was to create a directory named “test_19_52” within my home folder. I then created a file named “testfile_1952.txt” within that directory and just added a few comment lines to it. I then moved that directory to /media/Unencrypted/

Terminal threw this error: mv: failed to close ‘media/Unencrypted/test_19_52/testfile_1952.txt’: Input/output error

My Google Drive has the folder created but no file. No file exists in my temp directory (rclone_upload) either.

New Pastebin Log
https://pastebin.com/rAr3m1N7

I am running this as user “brian” which is a member of sudoers group. Any considerations that I am overlooking there? This seems so strange to me.


#7

You can’t write to the upload directory you have specified:

2019/02/10 19:54:18 ERROR : Unencrypted/test_19_52/testfile_1952.txt: Failed to copy: mkdir /home/brian/rclone_upload/Unencrypted/test_19_52: permission denied

Not but your permissions are wrong somewhere along the way.


#8

Silly me. I thought I had already chown that directory but apparently not. It seems to be working after that and I believe your thought is correct in that it will create the directories but not upload any files until after the cache-tmp-wait-time has expired. The directory was created in my Google Drive but the file is not.

Appreciate all the help. And thanks for everything you do on here. Your mount commands got my started in the right direction and it seems you’re everywhere on these forums.


#9

Best way to learn :slight_smile:

Happy you got it working and appreciate the kind words.