Rclone cache recommended settings for Plex?

I am using GDrive. Streaming low bitrate movies works, but anything big results in period buffering.

I have set up rclone cache (own api key) pointing to the encrypted bucket. then there is a decryption remote. and then mount the decrypted remote with default settings.

chunk_size = 5M
info_age = 6h
chunk_total_size = 10G

and I use --allow-other and --read-only for the mount.

My internet is 20mb/s which I can achieve using rclone copy. I am using a quad-core xeon 3.5GHz with 32GB of ram.

I have tried different settings without making any difference.

Can someone recommend any specific tweaks to my config?

Edit: I can see that I get frequent errors like this low level retry 2/10: unexpected EOF

I posted the same thing just a little earlier than you at:

Those are either drive closing your connections or a networking error of some kind, so not completely unusual.

Is the recommended config going from cache->decrypt->GD or decrypt->cache->GD ?

I’ve seen a lot of folks say both and I’m not sure what it really should be or does it even matter.

The second one… create a cache remote which is pointing to your encrypted google drive remote.

Create another crypt remote (set to decrypt) pointing at your cache. Now mount this decrypted cache remote

So in the OP’s post, he’s got it backwards.

That all depends on how you read it. Basically you want to cache the encrypted Google drive. Then have a remote decrypt the cache, and this is what is read. Should have 3 remotes in the following structure

GDrive Remote -> Google Drive (encrypted)
Cache Remote -> GDrive Remote (encrypted)
Crypt Remote -> Cache Remote (decrypted)

Mount the crypt Remote.

I edited the original post for clarity on the order in which I am working. Pretty sure that is correct.

No matter the variations of cache config I get stuttering. chunk_size of 1M is certainly better than 10M, but not different from 5M.

Maybe it is the mount settings? Any advice on that front?

I added:


to my rclone mount as I have 32GB of memory on my server so it would take quite a lot of streams to knock that out :slight_smile:

Each file that gets read can chew up 256MB of memory though.

Thanks, I followed your post and tried your mount config. Same result.

I get a ton of Unexpected EOF or Chunk Retry Storage in the DEBUG log and the video never smoothly for even a couple of seconds…

I can see in my network monitor that not much is happening either. with the default config it is working, but not enough for smooth playback.

Did you try to mount without the cache and just play that one file?

When I did that, it showed me the cache was messed up so I ran a mount with


to clean it up and then it rebuilt the cache.

I purged cache-db. Tried with just the –buffer-size=256M on mount and 1M for cache-chunk-size in the cache remote and it seems to be back to where I started.

Not many errors, just a lot of chunk retry storage. Playback is ok for 10-20 seconds until it has to buffer again…

What’s the bitrate of the movie you are trying to play? In your first post, you mentioned your line is only 20Mb/s down?