Rclone Cache - Plex Integration cache worker

How do i know that plex integration is working? I can just see one cache worker doing job “worker-0”.

Im using Windows 10.

My mount settings:

rclone mount gcryptcache:\ X: --config “C:\Users\USER.config\rclone\rclone.conf” --allow-other --fast-list --dir-cache-time 5m --buffer-size 10M --cache-chunk-size 20M --cache-info-age 24h --cache-read-retries 5 --log-level DEBUG --cache-db-path E:\Rclone

rclone config:

type = drive
client_id = ID
client_secret = SECRET
scope = drive
root_folder_id =
service_account_file =
token = TOKEN

type = crypt
remote = gdrive:/gdrive
filename_encryption = standard
directory_name_encryption = true
password = password
password2 = password2
show_mapping = false

type = cache
remote = gdrive:/gdrive
chunk_size = 20M
info_age = 1d
chunk_total_size = 100G
workers = 4
plex_url =
plex_username = plex_username
plex_password = plex_password

type = crypt
remote = gcache:/
filename_encryption = standard
directory_name_encryption = true
password = password
password2 = password2

I can see that it connect to Plex:

2018/11/04 17:39:24 DEBUG : Saving config “plex_token” = “PLEX_TOKEN” in section “gcache” of the config file
2018/11/04 17:39:24 INFO : gcache: Connected to Plex server:

Only one cache-worker:

2018/11/04 17:39:28 DEBUG : worker-0 <7igf41iusqfds4jg4jerifv9di5h5hge99sn986s3apncb65oq63dsb2bvu3tepvq4ur2q4in7gqdvlgikaslkvntdgo5b7b9nog7pg>: downloaded chunk 20971520

You have to play something and it picks up more as you play.

I did, those logs are from movie, but its only show one cache-worker “worker-0”


Missing the part of the log that would say if the Plex notified it was playing or not.


I don’t see any “confirmed by external reader” which normally happens if you start to play something.

My encrypted log looks like:

Apr  4 09:12:32 gemini rclone[25936]: tnvepu36qiohcun8v84ddhsam0/p7048hm1bicgno3fi9cgheicnm2570rbug72e0ehiakrlbpnf2f0/6qd3a6mt2lqhh1o4keott622tpkerps8bam88evh9mmnde93q180: confirmed reading by external reader

I would surmise that’s why you don’t see an uptick as it doesn’t detect it being played.

Is there any settings on Plex that i have to do and any idea why it dont work for me?

Here another log:

Looks like you are on a beta version. I would try the latest release and maybe pop back a release to see if it shows in the logs after that.

I think it’s probably a bug as I can see the connected message so that’s working:

2018/11/04 23:35:18 INFO  : gcache: Connected to Plex server:

but if you play something, you aren’t seeing the confirmed message after that.

The chunk retry messages do seem out of place. Did you change the chunk size and not clean up the chunk tmp dir?