Rclone authorize incorrectly parses input if dash exists in string value

What is the problem you are having with rclone?

can't authorize with credentials if they contain dash symbol

What is your rclone version (output from rclone version)

rclone v1.54.0

  • os/arch: darwin/amd64

  • go version: go1.15.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

MacOS Catalina

Which cloud storage system are you using? (eg Google Drive)

OneDrive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone authorize "onedrive" "12311123-048a-1234-b914-b22ed10cd123" "-G23M6ts2.~V_RewSp123R8l9F_V0jq124"

The rclone config contents with secrets removed.

new, empty config

A log from the command with the -vv flag

Error: unknown shorthand flag: 'G' in -G23M6ts2.~V_RewSp123R8l9F_V0jq124

hello and welcome to the forum,

perhaps try ' instead of " or no quotes at all

Perhaps -- before the last string:

rclone authorize "onedrive" "12311123-048a-1234-b914-b22ed10cd123" -- "-G23M6ts2.~V_RewSp123R8l9F_V0jq124"

This should work.

If it does, then we should change the help rclone prints for a remote auth to reflect that.

Seems it already does reflect that:

it works, thank you.

I suspect that was Klaus Post - always thorough :slight_smile: