Rclone added {} to mount

What is the problem you are having with rclone?

Hi, I am running in docker and this is my compose

    image: ghcr.io/hotio/rclone:release
    hostname: ${DOCKERHOSTNAME}
    container_name: rclone
      - RCLONE_CONFIG=/config/rclone.conf
      - apparmor:unconfined
      - SYS_ADMIN
      - /dev/fuse
      driver: json-file
        max-file: ${DOCKERLOGGING_MAXFILE}
        max-size: ${DOCKERLOGGING_MAXSIZE}
    restart: unless-stopped
      - /mnt/gdrive:/mnt/gdrive:shared
      - ${DOCKERCONFDIR}/rclone:/config
    command: mount "gdrive:"  "/mnt/gdrive" --allow-other --uid "1000" --gid "1000" --umask "022" --rc --rc-addr localhost:5572 --rc-no-auth --drive-skip-gdocs --fast-list --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 2048M --buffer-size 64M --poll-interval 1m --dir-cache-time 168h --timeout 10m --drive-chunk-size 64M

but from last few weeks I am seeing the the mounted drive with {} like this
gdrive{2aqQr}: 1.0P 1.7T 1.0P 15% /mnt/gdrive

What is your rclone version (output from rclone version)

rclone v1.55.1

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 18.04LTS

Which cloud storage system are you using? (eg Google Drive)

Google Drive

I have mounted this Google Drive on three different machines with same config and compose and all three are mounted with {} but with different values in it.

I am not sure what happened but it was alright previously.

Thank you


that is due to a recent change and is documented

and --fast-list does nothing on a mount, so that can be removed

Thank you so much and always you reply so quick.

I removed the --fast-list but is there anyway I can remove {} from mount? Might not be possible but I thought I should ask because I cannot find in the documentation.

Thanks again

not sure what you mean, can you post an example?

When I do df -h I see my mount in their gdrive{2aqQr}: and I'm not sure how to remove the curly brackets.

i see what you mean now.

why is that a problem as the mount is accessed via the mountpoint?

remove gdrive flags from the command line and put them into the config file,
then rclone would not need to use the {}

What problem are you having with that? That just means you have an environment variable configured.

Hi, no problem everything is working fine. I was just curious if we can remove it from mount.

asd explained and I also read the documentation and seem like remove command and updating conffig will do the job.

You guys always help me out.


Why do you want to remove it though?

No real reason but to keep it tidy. Having {} when all other mounts are consistent. That's all

Hi @asdffdsa apologise I am back you know how can I adopt my command into rclone.conf

This is my current .conf

type = drive
client_id = *********
client_secret = ************
scope = drive
token = ******************
root_folder_id = 0ALitjOsfgrtthfdsxKUk9PVA


please remove the value for root_folder_id

Hi, its a made up value. I changed it before I posted but I will remove it. Thank you

at this point, what do you need help with?

I need to remove the command: line from my compose and use it in my config so I can remove the curl brackets :slight_smile: and I'm not sure how to adopt the command line arguments into config file. That's where I need your assistance. Thanks

this is documented for each flag,

for example https://rclone.org/drive/#drive-skip-gdocs

--drive-skip-gdocs, in the config file would be skip_gdocs = true

Thank you so much, this makes lot of sense. Much appreciated.

Thats how I added, this is just an example

type = drive
client_id = **
client_secret = **
scope = drive
token = **
root_folder_id = **

type = cache
remote = gdrive:
chunk_size = 5M
chunk_total_size = 1G

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.