RC - Transfers=1 not working

Hello all,

I have the following setup:

  • rclone running in a docker container using rcd and serving the web gui

  • Win 10 machine that I use to run the following script:

    rclone rc sync/copy srcFs="freenas:/data" dstFs="GoogleDrive_NAS_crypt:NAS" --rcaddr= --rc-user=james --rc-pass=rclone _async=true -vv --checksum --transfers=1 --checkers=4 --contimeout=60s --timeout=300s --retries=3 --low-level-retries=10 --stats=1s --stats-file-name-length=0

This works and the upload begins, showing correctly in the web gui. However, many of the parameters are ignored. I would like the transfers=1 to be adhered to, rather than it always defaulting to 4. I have tried with = and a space but neither works.

Please could you review the code and advise? I run this from a .bat file.

Unfortunately you can't pass parameters like that to the RC. The easiest thing to do is to put them on the rcd.

If you want to set them via the RC then check out the options blocks in the RC docs.

I want to make this easier to do in the RC in future.

Ahh you mean just launch the rcd with those parameters? @ncw

Yes. You can add most parameters to the rcd command

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.