Questions regarding config

Hello !

I`m nearly new to Rclone and have some questions regarding the config.

My initial setup works very well and is as follows.

[gdrive]
type = drive
client_id = My.Client_ID.apps.googleusercontent.com
client_secret = My.Client.Secret
scope = drive
token = {"access_token":"BlaBlaBla"}
team_drive = MyTeamDrive

[gdrivecrypt]
type = crypt
remote = gdrive:/secured
filename_encryption = standard
directory_name_encryption = true
password = XXX

With this setup I have full access to all files and Folders... no restrictions...

I would like to have a setup/config file where I just have "read access" to all files... crypted and uncrypted.
Is my understanding correct, that I have to create an Access Token, which only has read rights ?
I know that there is a Flag (--read-only) but a nicer solution would be to use an access token that has
read-only privileges to do this.

Can this be setup and if yes, how ?

Thanks in advance for any help!

best regards
Michael

That would be the best way, however... Change the scope of the drive to be read only.

Using --read-only on the mount will ensure it doesn't write to the backend. I'd do both as setting --read-only allows rclone mount to tell apps very quickly that they can't write without having to contact google drive.

Hello !

First of all...Thanks for your answer..... :slight_smile:

I tried the Flag "drive.readonly" in my config File but had no success.
When I mount the Drive I still have Full Access to everything. I can delete, rename, or create
a new File...
I have also created an Access Token that has read-only privileges. This works perfectly for 3600 seconds (1 hour), but after that hour, the token expires and I get the message "Access denied".
When I change back to my initial config File where I have Full access everything works fine.
The Access Token is automatically renewed by the Google servers.

Does anyone have any idea why my access token with read only privileges is not automatically renewed ?

Thanks for your help in advance!

best regards
Michael

You need to re auth when you do that, easiest way is rclone config reconnect gdrive:

Then it should work properly and you shouldn't have to manually make an access token.