Problems creating automount rclone

What is the problem you are having with rclone?

I tried to create a systemd service to mount a onedrive drive after reboot.It mounts it perfectly, the real problem comes up after trying to access or list the directory with a non-root-privileged user, returning:
ls: cannot access '/mnt/KILLER_QUEEN': Permission denied.

When i to ls -l /mnt, it returns me this:

d????????? ? ?     ?       ?            ? KILLER_QUEEN

Run the command 'rclone version' and share the full output of the command.

rclone v1.66.0-beta.7581.fba2d4c4a
- os/version: raspbian 12.4 (64 bit)
- os/kernel: 6.1.0-rpi7-rpi-v8 (aarch64)
- os/type: linux
- os/arch: arm64 (ARMv8 compatible)
- go/version: go1.21.5
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Onedrive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

More than a command, it's the service I tried to start:
Here's the complete service:

[Unit]
Description=rclone onedrive mount killer queen
Requires=network-online.target
After=network-online.target

[Service]
Type=simple

ExecStart=/usr/bin/rclone mount --config=/home/user/.config/rclone/rclone.conf --vfs-cache-mode writes KILLER-QUEEN:/KILLER-QUEEN-2/KILLER-QUEEN /mnt/KILLER_QUEEN
ExecStop=/bin/fusermount -zu /mnt/KILLER_QUEEN

Restart=on-failure
RestartSec=15
[Install]
WantedBy=default.target

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[KILLER-QUEEN]
type = onedrive
token = XXX
drive_id = XXX
drive_type = business

A log from the command that you were trying to run with the -vv flag

I can show you that the service start correctly, so there must be something wrong with that

 mnt-onedrive.service - rclone onedrive mount killer queen
     Loaded: loaded (/etc/systemd/system/mnt-onedrive.service; enabled; preset: enabled)
     Active: active (running) since Mon 2024-01-01 14:39:02 CET; 14min ago
   Main PID: 26002 (rclone)
      Tasks: 12 (limit: 8741)
        CPU: 1.235s
     CGroup: /system.slice/mnt-onedrive.service
             └─26002 /usr/bin/rclone mount --config=/home/ganxo/.config/rclone/rclone.conf --vfs-cache-mode writes KILLER-QUEEN:/KILLER-QUEEN-2/KILLER-QUEEN /mnt/KILLER_QUEEN

Jan 01 14:39:02 LOLITA systemd[1]: Started mnt-onedrive.service - rclone onedrive mount killer queen.

thanks beforehand!

You run your mount as root hence others might have problem accessing it.

Add --allow-other flag to your mount command.

In addition edit /etc/fuse.conf file and uncomment user_allow_other lline.

Yes. it was just that. Thank you for your help and sorry for posting for silly things, I'm still learning how fuse and stuff works!

Happy new year and have a nice day!

NP. There are no stupid questions - only answers:)

Thank you for posting all details - it made solving this easy.

Happy NY!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.