Problem with symlinks and --links


I think that you are right that --links should always enable this.

Can you give this a go? It shouldn't need the --local-zero-size-links (and it deprecates that flag since it will always be enabled).

v1.56.0-beta.5475.94add5c00.fix-local-readlink on branch fix-local-readlink (uploaded in 15-30 mins)

I wasn't sure which version to try so I used the 8a version which ran on my machine before

There wasn't a armv8a.gz in the main folder
This seems to have been compiled yesterday.

But it had the same error as before. It may be that this version is not updated (in the testbuilds subfolder) - as an aside will Google ask for re-authentication each time (as it did now) if I keep the file name the same with a different build (i.e. just rclone)

I think that is the right version.

Can you just double check you are running the right rclone version and run rclone version and check the version is v1.56.0-beta.5475.94add5c00.fix-local-readlink?

Apologies I ran the old version by mistake previously - I can confirm that all now seems good

Thank you for testing :slight_smile:

I've merged this fix to master now which means it will be in the latest beta in 15-30 minutes and released in v1.56

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.