Problem with access to onedrive buiseness

What is the problem you are having with rclone?

Dear community,
I can't access my one-drive buiseness account. When I come do the login page
and when I write the email-adress for this account, I get the message:

That Microsoft account doesn't exist. Enter a different account or get a new one.

But it surely exists!
From the webmaster of the site I got the information, that rclone has to communicate with "O365"
Any ideas, what I can do?
My rclone version is 1.36, my OS is ubuntu 18.04 (xubuntu).

Thanks for Your help!

1.36 is a number of years old. Pleas download the latest and try again.

Thanks for Your help!
I've downloaded the newest version, and I had a little more luck.
I could authorize my machine.
I came to this point now:

Choose a number from below, or type in an existing value
1 / OneDrive Personal or Business
\ "onedrive"
2 / Root Sharepoint site
\ "sharepoint"
3 / Type in driveID
\ "driveid"
4 / Type in SiteID
\ "siteid"
5 / Search a Sharepoint site
\ "search"
Your choice>
I typed in 1
I got
Found 1 drives, please select the one you want to use:
0: OneDrive (business) (some code left here)
I typed the "0" and I've got:
Found drive 'root' of type 'business', URL (some code left)
Is that okay?
y) Yes (default)
n) No
I typed "y" and I've got

2020/04/08 19:54:34 Failed to save config after 10 tries: Failed to create temp file for new config: open /home/stefan/.config/rclone/rclone.conf001297743: permission denied

What can I do now?

Just run:

mkdir -p /home/stefan/.config/rclone

and give it a go again

Sorry, the same error message again!

Are you running as the same user? Seems like you have a permissions issue with your home directory.

Can you show the permissions? Can you create a file yourself?

Thanks, maybee this solved the problem.

I typed sudo chown -R myname /home/myname

and I came to the end of the config process. Maybee it has to do do that I did the installation with

> curl | sudo bash
maybee sudo caused this problem?

Your install is fine. You run sudo so you can install it to your system as that's normal.

Is it working now or not working as your message is not clear.

to be honest: I still have problems.
I've made (via the browser) a folder with 2 small files in OneDrive.
Then I typed

rclone lsd remote:

and I got:

2020/04/08 20:40:21 Failed to create file system for "remote:": didn't find section in config file

Is the first issue you had solved? Did you authenticate and get it created?

When you run:

rclone config file

Can you share the contents of the file with keys and passwords and such removed?

The error says you named your remote something else.

what is the name of the onedrive remote?
you can do a rclone listremotes

change remote: to the name of the remote listed in that command

rclone listremotes
Enter configuration password:

try this

rclone lsd onedrive:

it seems to work!

rclone lsd onedrive:

      -1 2020-04-08 20:38:30         2 test

I have folder on my onedrive-account called test. There are 2 files.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.