Problem sharing a mounted remote

Please help.

I´ve created two remotes:
Remote #1
type = drive
client_id =
client_secret =

Remote #2
type = crypt
remote = Gdrive:Drive
filename_encryption = standard
directory_name_encryption = true
password2 =

Then i mount the [Encrypt] remote on a Ubuntu Linux 16.04.4 with this command:
“rclone mount -v --allow-other --buffer-size 32M --gid 1001 --umask 777 --dir-cache-time 1h --poll-interval 2m Encrypt: /mnt/cloud”

This woks great. When i share “/mnt/cloud” with samba with this config:
path = /mnt/cloud
available = yes
browsable = yes
writable = yes
read only = no
valid users = adminit
public = yes

Now when i connect from a Windows 10 Pro with the user “adminit” i see folders inside my remote but when i try to open i get an error.
I can create new files and folders but if i copy new files with rclone copy then i get the error.

Have you tried with the latest beta?

That has got some fixes for samba sharing in and it might help.

1 Like

Will try this evening. Tha, you

1 Like

Followed your advise and everything works now. Thank you so much.

1 Like

Great - thanks for testing. 1.41 is now released and should be fixed in the same way.