Problem rclone symlinks in SFTP

What is the problem you are having with rclone?

I want to make a synchronization by skipping the symbolic links, if the origin in a local drive is no problem (option --skip-lines enable). But if the source is SFTP - skip-links does not work, I copy the symbolic links.

What is your rclone version (output from rclone version)

rclone v1.50.1

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 16.04 LTS

Which cloud storage system are you using? (eg Google Drive)

Origin SFTP

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync aplicaciones:/var/www/ onedrive-deltatec:

aplicaciones: SFTP Server

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

--skip-links only applies to the local backend as you've discovered.

The SFTP backend is somewhat special as it is the only one which supports symlinks.

What would you think about if it if this was an sftp option --sftp-skip-links that would fit into the architecture of rclone and would be quite easy to implement.

If you'd like to see that then please please make a new issue on github

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.