Problem entering password in rclone config

What is the problem you are having with rclone?

During adding or editing remote via rclone config on windows(admin rights) or android phone (termux) cant enter the password, no any symbols typing, paste also not working. Entering login and other is ok, but pass - no. Even thought to generate random and edit in file but found that pass is encrypted

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.0

  • os/version: Microsoft Windows 8.1 Pro (64 bit)
  • os/kernel: 6.3.9600.0 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.21.4
  • go/linking: static
  • go/tags: cmount

rclone 1.60.1-termux

  • os/version: unknown
  • os/kernel: 4.14.197-Xtended (aarch64)
  • os/type: android
  • os/arch: arm64
  • go/version: go1.19.3
  • go/linking: dynamic
  • go/tags: noselfupdate

Which cloud storage system are you using? (eg Google Drive)

Mega

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config
n
M1
31
username@mail
y
(nothing can be entered)

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[APP]
type = drive
scope = drive
token = XXX
team_drive =

[BKP]
type = drive
scope = drive
token = XXX
team_drive =

[DLOAD]
type = drive
scope = drive
token = XXX
team_drive =

[DOC]
type = drive
scope = drive
token = XXX
team_drive =

[FOTO]
type = drive
scope = drive
token = XXX
team_drive =

[LOC]
type = drive
scope = drive
token = XXX
team_drive =

[LOG]
type = drive
scope = drive
token = XXX
team_drive =

[M0]
type = mega
user = XXX
pass = XXX

[M1]
type = mega
user = XXX

[MAIN]
type = drive
scope = drive
token = XXX
team_drive =

[PIC]
type = drive
scope = drive
token = XXX
team_drive =

[TRK]
type = drive
scope = drive
token = XXX
team_drive =

A log from the command that you were trying to run with the -vv flag

Cant apply to this command

welcome to the forum,

just now, worked for me, windows 11 pro + v1.65.0
and worked for me on termux

this is from windows

Configuration complete.
Options:
- type: mega
- user: user
- pass: *** ENCRYPTED ***
Keep this "megatest" remote?
y) Yes this is OK (default)
e) Edit this remote
d) Delete this remote
y/e/d> y

can you run rclone config -vv for debug output and post that.
make sure to redacted any secret info.

that is correct but you can obscure the password and paste the into the config flie.

  1. rclone obscure secretpassword
  2. paste that into the config file.

C:\rclone-v1.65.0-windows-amd64>rclone config -vv
2024/01/06 17:21:38 DEBUG : rclone: Version "v1.65.0" starting with parameters [
"rclone" "config" "-vv"]
2024/01/06 17:21:38 DEBUG : Using config file from "C:\rclone-v1.65.0-windows-a
md64\rclone.conf"
Current remotes:

Name Type
==== ====
APP drive
BKP drive
DLOAD drive
DOC drive
FOTO drive
LOC drive
LOG drive
M1 mega
MAIN drive
MUSIC drive
PIC drive
RAPID drive
TRK drive

e) Edit existing remote
n) New remote
d) Delete remote
r) Rename remote
c) Copy remote
s) Set configuration password
q) Quit config
e/n/d/r/c/s/q> e

Select remote.
Choose a number from below, or type in an existing value.
1 > APP
2 > BKP
3 > DLOAD
4 > DOC
5 > FOTO
6 > LOC
7 > LOG
8 > M1
9 > MAIN
10 > MUSIC
11 > PIC
12 > RAPID
13 > TRK
remote> 8

Editing existing "M1" remote with options:

  • type: mega
  • user: wv.meg*@gmail.com

2024/01/06 17:21:49 DEBUG : M1: config in: state="all", result=""
2024/01/06 17:21:49 DEBUG : M1: config out: out=&{State:all-set,0,false Option:
wv.meg
@gmail.com OAuth: Error: Result:}, err=
2024/01/06 17:21:49 DEBUG : M1: config: reading config parameter "user"
Option user.
User name.
Enter a string value. Press Enter for the default (wv.meg
@gmail.com).
user>

2024/01/06 17:21:53 DEBUG : M1: config in: state="all-set,0,false", result="wv.
meg
@gmail.com"
2024/01/06 17:21:53 DEBUG : M1: config out: out=&{State:*all,1,false Option:<nil

OAuth: Error: Result:}, err=
2024/01/06 17:21:53 DEBUG : M1: config in: state="*all,1,false", result=""
2024/01/06 17:21:53 DEBUG : M1: config out: out=&{State:*all-set,1,false Option:
OAuth: Error: Result:}, err=
2024/01/06 17:21:53 DEBUG : M1: config: reading config parameter "pass"
Option pass.
Password.
Choose an alternative below.
y) Yes, type in my own password
g) Generate random password
y/g> y
Enter the password:
password:
##################
Thats all

i assume that you pressed ENTER after typing the password

To press enter i must enter symbols but i cant enter or paste anything. If i pres enter it says to confirm pass, but it will be empty
Strange that even on android terminal it does not work

this works for me, thanks. But need to solve it by ordinary method

welcome


you have the same exact issue on two very different platforms, using two different version of rclone.
yet, just now, i created a mega remote on windows and termux.
imho, to me, that means you are doing something simple wrong.

correct, rclone will ask for the password twice, so just type the password, press enter.

Option user.
User name.
Enter a value.
user> user

Option pass.
Password.
Choose an alternative below.
y) Yes, type in my own password
g) Generate random password
y/g> y
Enter the password:
password:
Confirm the password:
password:

Edit advanced config?
y) Yes
n) No (default)
y/n>

Video 55s you can see online

sorry, not sure what you are doing there, with all that many random keystrokes and with that pop-up menu.

let's keep this simple, as a test:
each time you are asked for a password, just type a single character and then press enter.

There is no issue at all. This is how rclone works.

You do not see anything when typing password.

Maybe it would be nice enhancement to show entered characters as e.g. *

Password: ******

But for now it is how it is.

Thanks to all, i get it. The pass was just invisible, not even *****, very unusual, it would be right to warn users during entering that it is nornal or make some *, cause you even cant see the length of pass

This password input field behaviour is quite common in security conscious solutions and systems. And it is very common there. You will never see typed password characters when logging into Open BSD etc.

But I think that for rclone config **** approach would be better as it is one off action only when new remote is created. Existing mode is definitely overkill and a bit tinfoil hat style IMO:).

Either way it is only cosmetic aspect so unless you are willing to submit PR with required modifications it might never happen.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.