Preserving modtime metadata when copying to Seafile

What is the problem you are having with rclone?

Trying to copy some legacy files from local disk to a Seafile remote. Data transfer generally works very well but the local last-modified metadata of files and folders is not preserved on the remote Seafile.

The Seafile desktop client syncs files and folders including their last-modified time, so Seafile definitely supports that feature.

Run the command 'rclone version' and share the full output of the command.

rclone v1.64.0
- os/version: ubuntu 22.04 (64 bit)
- os/kernel: 6.2.0-32-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.21.1
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Seafile Professional Edition 10.0.9

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy --progress -M Projects/2019/ seaf:2019

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

type = seafile
url = XXX
user = XXX
pass = XXX

A log from the command that you were trying to run with the -vv flag

I was maybe expecting something like "--metadata or -M flag not supported on this type of remote". However the log doesn't show anything unusual, files are just transferred.

welcome to the forum,

according rclone docs, rclone does not support hash and modtime for seafile.

and in general, for most/all providers, rclone has no support for modtime for folders.

No mtime is definitely their native API limitation but you can try S3 and WebDAV APIs which I think are also supported - so maybe you can make it work with these?

rclone can definitely read modtime from Seafile:

$ rclone lsl seaf:2019
170592964 2018-05-17 19:25:04.000000000

However when copying a file from Seafile to local storage the modtime isn't preserved either.

Seafile doesn't support an S3 API, it can use S3 as storage. WebDAV is supported, I will give it a try.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.