Plex Library Scan takes much longer with CRYPT vs ENCFS

I cant really figure out whats the problem but I can tell for sure that Plex Library Scan takes much longer with CRYPT compared to ENCFS while both are mounted with rclone mount.

But simple check (list all folders/files with size/date …)
ls -lahR /storage/acdcrypt/ (rclone crypt mount)
compared to /unencrypted-encfs (rclone acd mount layered with encfs)
produces same result in speed.

Playback, file copy etc… works more or less the same.

I was checking Plex logs during the scanning and there is nothing really obvious the only thing i notice in plex scanner log is tons of warnings ( not sure if i had them before )
WARN [FFMPEG] - Could not find codec parameters for stream 3 (Subtitle: hdmv_pgs_subtitle): unspecified size
and really few of:
ERROR - [FFMPEG] - SEI type 5 size 5552 truncated at 5535
( this is related to the scaning as i made sure no streams/syncs were running during this time )

However RCLONE MOUNT LOG had tons of
2017/01/29 23:18:43 fuse: -> [ID=0x1231] Lookup error=ENOENT
by tons I mean 50 to 60 per second. ( i think those are from unionfs fuse)
full log:

@ncw any idea why performance would be so much impacted . ( by much i mean like 5 to 10 times longer )

UPDATE: Before heading to bed I updated to latest beta:
rclone v1.35-54-gff8f11dβ ( before i was running from v1.35-47-g29c6e22 eg couple of hours older :stuck_out_tongue: ) and the scans preforms great eg on pair with previous encfs if not even better.
So it seems on of those updated fixed it: