Plex having issues reading mounted Google Drive

Hello, Linux noob here. I am trying to use Plex, using media from an rclone mounted Google Drive. For some reason, I can read the contents of the mounted folder, but Plex doesn't even want to open/read it.
(if I try to open /mnt/gdrive manually, doesn't even let me click on the folder)
(if I try to open /mnt/gdrive from the panel on the left, the folder shows up empty)
I'm using a systemd service to run the rclone mount on every reboot, in case the power goes out.
Here are the contents of the said service file:

Description=RClone GDrive mount
#Mount rclone fs
ExecStart=/usr/bin/rclone mount
--dir-cache-time 72h
--config "/home/pi/.config/rclone/rclone.conf"
--vfs-cache-mode writes
--umask 000
GDriveEdu: /mnt/gdrive
#Unmount rclone fs
ExecStop=/bin/fusermount -u "/mnt/gdrive"
#Restart info

I am honestly unsure if this is the right place to ask for support for my issue, if so, please excuse me and point me in the right direction.

Thank you in advance.

hello and welcome to the forum,

try adding

--allow-other                            Allow access to other users.

Thank you for your quick response, however, this did not fix my issue, in fact, it made the service not launch at all.

Can you share your service file and what you changed?

What version of rclone are you running?

I shared the service file in the OP.
Here's my version:

You need to update the version as that's a number of years old.

The OP has your "starting" service file. You added "--allow-other" somehow and now it doesn't start so I can't see what you changed to make it not work other than I'm not sure if 1.45 even has allow other since it's ancient.

I wasn't aware I had an old version. Sorry, I'll update now.
All I changed is that I added "--allow-other" to ExecStart, like so

That looks like it'll work from what you just pasted after you update it.

Sadly, even after updating, it didn't work. Here's the error, but as far as I see it's the same as last time.

You need to fix /etc/fuse.conf so user_allow_other is uncommented:

felix@gemini:/opt/Tautulli/logs$ cat /etc/fuse.conf
# /etc/fuse.conf - Configuration file for Filesystem in Userspace (FUSE)

# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#mount_max = 1000

# Allow non-root users to specify the allow_other or allow_root mount options.

Sweet, that worked, gonna check if Plex can read the folder now. Thanks for the help :smiley:

Yep, Plex can now read the mount. Thanks a lot!

1 Like

Hey, new issue. Once I close the SSH session, the service stops and my Google Drive gets unmounted :confused:
I tried adding --daemon \ to my service file, but this results in the service not being able to start..

Whoop. I found a fix (I think, it's working so far.)

sudo loginctl enable-linger pi

This fixed my issue, and now the service keeps running after session end :slight_smile:
Edit: also had to remove --daemon from the service file :stuck_out_tongue:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.